This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: [Xen-devel] [Xen-usersl] Xen Kernel tree on Ubu

On Sun, Nov 08, 2009 at 04:45:30PM +0530, Tej wrote:
> On Sun, Nov 8, 2009 at 4:17 PM, Simon Horman <horms@xxxxxxxxxxxx> wrote:
> > On Sun, Nov 08, 2009 at 11:14:40AM +0530, Tej wrote:
> >> All,
> >>
> >> Recently I have tried Xen 3.4.1 (even xen-unstable.hg) and Linux
> >> tree on new ubuntyu karmic koala.
> >> I have tried this combination on different machine AMD64, intel i386,
> >> but every time I boot process is stop at
> >>
> >> "Waiting for root file system" , After some time the promt drops to
> >> initramfs shell.
> >> I am sure the problem is not due to NOT selecting prooper SATA
> >> controller or something ike that.....
> >>
> >> I have tried similar hardware configuration with Xen on Jaunty it
> >> works without any problem.
> >> I am just wondering why it is refusing to work on Karmic, possible reasons.
> >> 1. gcc 4.4
> >> 2. make version
> >> 3. your thoughts please????
> >>
> >> I have tried pvops kernel, it works but I need tree so any 
> >> thoughts???
> >
> > It sounds a lot like the correct modules aren't being loaded up for
> > by the initramfs (that was presumably created while
> > running a much newer kernel). When you drop into the initramfs shell
> > can you see the root device?
> Thats the issue, boot process tries to detect root filesystem, but it
> can't. Some reasons for this I know are:
> 1. Storage controllers are not in kernel and initramfs
> 2. Pointing wront root device

So the root device (e.g. /dev/sda1) exists when you get dumped
into the initramfs but it isn't being mounted by the kernel?

> I could say that both of the problem does not exist.
> Now question why configuration worked on jaunty and why not in karmic??

Possibly because the name of the relevant modules and/or the root device
has changed?

Xen-users mailing list