This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] [Xen-usersl] Xen Kernel tree on Ubuntu Kamic

To: Tej <bewith.tej@xxxxxxxxx>
Subject: Re: [Xen-devel] [Xen-usersl] Xen Kernel tree on Ubuntu Kamic
From: Simon Horman <horms@xxxxxxxxxxxx>
Date: Sun, 8 Nov 2009 21:47:14 +1100
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, xen-users <xen-users@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Sun, 08 Nov 2009 02:47:44 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <f1c9d250911072144v6474eca9ue207b6a90a5909fe@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <f1c9d250911072144v6474eca9ue207b6a90a5909fe@xxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.20 (2009-06-14)
On Sun, Nov 08, 2009 at 11:14:40AM +0530, Tej wrote:
> All,
> Recently I have tried Xen 3.4.1 (even xen-unstable.hg) and Linux
> tree on new ubuntyu karmic koala.
> I have tried this combination on different machine AMD64, intel i386,
> but every time I boot process is stop at
> "Waiting for root file system" , After some time the promt drops to
> initramfs shell.
> I am sure the problem is not due to NOT selecting prooper SATA
> controller or something ike that.....
> I have tried similar hardware configuration with Xen on Jaunty it
> works without any problem.
> I am just wondering why it is refusing to work on Karmic, possible reasons.
> 1. gcc 4.4
> 2. make version
> 3. your thoughts please????
> I have tried pvops kernel, it works but I need tree so any 
> thoughts???

It sounds a lot like the correct modules aren't being loaded up for by the initramfs (that was presumably created while
running a much newer kernel). When you drop into the initramfs shell
can you see the root device?

Xen-devel mailing list