This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: [Xen-devel] [Xen-usersl] Xen Kernel tree on Ubu

To: Tej <bewith.tej@xxxxxxxxx>
Subject: [Xen-users] Re: [Xen-devel] [Xen-usersl] Xen Kernel tree on Ubuntu Kamic
From: Pasi Kärkkäinen <pasik@xxxxxx>
Date: Sun, 8 Nov 2009 13:37:27 +0200
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, xen-users <xen-users@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Sun, 08 Nov 2009 03:38:08 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <f1c9d250911072144v6474eca9ue207b6a90a5909fe@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <f1c9d250911072144v6474eca9ue207b6a90a5909fe@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.13 (2006-08-11)
On Sun, Nov 08, 2009 at 11:14:40AM +0530, Tej wrote:
> All,
> Recently I have tried Xen 3.4.1 (even xen-unstable.hg) and Linux
> tree on new ubuntyu karmic koala.
> I have tried this combination on different machine AMD64, intel i386,
> but every time I boot process is stop at
> "Waiting for root file system" , After some time the promt drops to
> initramfs shell.

Well.. it either means the driver for your SATA controller is not
loaded, the driver is misbehaving or the driver is too old to actually
support the controller.

> I am sure the problem is not due to NOT selecting prooper SATA
> controller or something ike that.....

You should enable/configure serial console and capture the full xen and
dom0 kernel boot logs so we can see what's wrong..

that's the easiest way to troubleshoot the problem.

> I have tried similar hardware configuration with Xen on Jaunty it
> works without any problem.
> I am just wondering why it is refusing to work on Karmic, possible reasons.
> 1. gcc 4.4
> 2. make version
> 3. your thoughts please????
> I have tried pvops kernel, it works but I need tree so any 
> thoughts???

Any particular reason for that?

Have you considered the novell/opensuse forward-ported 2.6.18 patches for 


-- Pasi

Xen-users mailing list