This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Re: xenoprof: operation 9 failed for dom0 (status: -1)

To: "Santos, Jose Renato G" <joserenato.santos@xxxxxx>
Subject: Re: [Xen-devel] Re: xenoprof: operation 9 failed for dom0 (status: -1)
From: Andrew Evans <andrewe@xxxxxxxxxxxxx>
Date: Mon, 16 Nov 2009 16:04:04 -0800
Cc: Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>, Dante Cinco <dantecinco@xxxxxxxxx>
Delivery-date: Mon, 16 Nov 2009 16:05:46 -0800
Domainkey-signature: a=rsa-sha1; s=serpent; d=yahoo-inc.com; c=nofws; q=dns; h=received:message-id:date:from:user-agent:mime-version:to:cc: subject:references:in-reply-to:content-type; b=zAyB3O8ZIzdwlkIZT7deKpAZwpyT0KxWQbvtRceXCxmJVoUaoVkUVF6TwBL6N+RH
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <8d2cca230911060927g1633a68dq8d7c1f63076475ed@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <8d2cca230911051715n5b9c1050g12bdf49c80b59053@xxxxxxxxxxxxxx> <EF547E542C520A4D858CFEF5B404D05360805E78A1@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx> <8d2cca230911060927g1633a68dq8d7c1f63076475ed@xxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20091014 Fedora/3.0-2.8.b4.fc11 Thunderbird/3.0b4
I too am experiencing this problem. My setup is much less bleeding-edge, however:

RHEL 5.3 dom0 (2.6.18-128.el5xen kernel)
xen-3.3.1 from gitco

Same error message in Xen dmesg ring buffer.


On 11/06/2009 09:27 AM, Dante Cinco wrote:
I initially tried OProfile 0.9.3 with the oprofile-0.9.3-xen-r2.patch but when I tried running "opcontrol --status" in dom0, I got an error message about cpu_set or cpu_type and prompted to use a newer version of OProfile (I think OProfile 0.9.3 doesn't recognized the Core i7 CPU I'm using). So I downloaded OProfile 0.9.5 and manually applied the same patch and it seems to work except for the problems I described in my previous email. I'm also using Jeremy's latest pvops with Dulloor's xenoprof.patch. I'm also using the patched OProfile 0.9.5 in domU (Linux

I realize I'm using a lot of new stuff like pvops (with Xen 3.5-unstable changeset 20330) and OProfile 0.9.5 but I thought I'd check with you to see if the problems I'm having sound familiar.



On Thu, Nov 5, 2009 at 6:05 PM, Santos, Jose Renato G <joserenato.santos@xxxxxx> wrote:
What version of OProfile are you using?
Did you apply the Xen patch available in http://xenoprof.sourceforge.net ?

From: Dante Cinco [mailto:dantecinco@xxxxxxxxx]
Sent: Thursday, November 05, 2009 5:16 PM
To: Santos, Jose Renato G
Cc: Xen-devel
Subject: xenoprof: operation 9 failed for dom0 (status: -1)


When I tried running "opcontrol --start" (after previously running "opcontrol --start-daemon") in dom0, I get this error message:

/usr/local/bin/opcontrol: line 1639: echo: write error: Operation not permitted

and this message in the Xen console:

(XEN) xenoprof: operation 9 failed for dom 0 (status : -1)

It looks like opcontrol is trying to do this: echo 1 > /dev/oprofile/enable

and it is failing. "operation 9" maps to XENOPROF_start which is consistent with running "opcontrol --start." At first, I ignored the error because it gave the indication "Profiler running" but after I ran "opcontrol --shutdown" followed by "opreport" in dom0, I got this error message:

error: no sample files found: profile specification too strict ?

Do you know why the write error is occurring? I followed the steps in xenoprof_tutorial.ppt.


_______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxx http://lists.xensource.com/xen-devel

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>