This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Re: xenoprof: operation 9 failed for dom0 (status: -1)

To: Dante Cinco <dantecinco@xxxxxxxxx>
Subject: Re: [Xen-devel] Re: xenoprof: operation 9 failed for dom0 (status: -1)
From: Dulloor <dulloor@xxxxxxxxx>
Date: Tue, 17 Nov 2009 02:02:31 -0500
Cc: Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>, "Santos, Jose Renato G" <joserenato.santos@xxxxxx>
Delivery-date: Mon, 16 Nov 2009 23:03:00 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=w1CFD5U7klKjUZofKdFQJtSKCDj+Qu9MVQ+qGIfQQq0=; b=T9Sejdw1aBjhO/mkwOQcDzjGyAmgM76o1W3WQgdRY5mHOvy44hilLgSLHSkTRtzQFV uXcNtJFURlKqSFel6sbHCzBh/05gdVUMlEccsVulgZMlLCMDD2uM/f3QgnFewrAK54Ms dupVFe5kkr6G+R9kocnOXQq2vp+Ge5nCCGy+c=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=li14CbDPFSPAAsR7L9V1yveWNLpfPWKxUOrsSiMzZYA7evlu6zuDZOK0TJIHsXnUp/ Pri2qM0DztkB0AIms25brLhGHBNj51fF09+12MpPbd+zz/OcRQqj6hVLlkAYTtr8JUcc tjQ0U/hUbwKBfCK2vHmS5+Y+xClm7ty2uCdUM=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <8d2cca230911060927g1633a68dq8d7c1f63076475ed@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <8d2cca230911051715n5b9c1050g12bdf49c80b59053@xxxxxxxxxxxxxx> <EF547E542C520A4D858CFEF5B404D05360805E78A1@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx> <8d2cca230911060927g1633a68dq8d7c1f63076475ed@xxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Yeah, I had to modify 0.9.3 to use it with i7. Can send you the patch tomorrow.


On Fri, Nov 6, 2009 at 12:27 PM, Dante Cinco <dantecinco@xxxxxxxxx> wrote:
> I initially tried OProfile 0.9.3 with the oprofile-0.9.3-xen-r2.patch but
> when I tried running "opcontrol --status" in dom0, I got an error message
> about cpu_set or cpu_type and prompted to use a newer version of OProfile (I
> think OProfile 0.9.3 doesn't recognized the Core i7 CPU I'm using). So I
> downloaded OProfile 0.9.5 and manually applied the same patch and it seems
> to work except for the problems I described in my previous email. I'm also
> using Jeremy's latest pvops with Dulloor's xenoprof.patch. I'm also
> using the patched OProfile 0.9.5 in domU (Linux
> I realize I'm using a lot of new stuff like pvops (with Xen
> 3.5-unstable changeset 20330) and OProfile 0.9.5 but I thought I'd check
> with you to see if the problems I'm having sound familiar.
> Thanks.
> Dante
> On Thu, Nov 5, 2009 at 6:05 PM, Santos, Jose Renato G
> <joserenato.santos@xxxxxx> wrote:
>> What version of OProfile are you using?
>> Did you apply the Xen patch available in http://xenoprof.sourceforge.net ?
>> Renato
>> ________________________________
>> From: Dante Cinco [mailto:dantecinco@xxxxxxxxx]
>> Sent: Thursday, November 05, 2009 5:16 PM
>> To: Santos, Jose Renato G
>> Cc: Xen-devel
>> Subject: xenoprof: operation 9 failed for dom0 (status: -1)
>> Renato,
>> When I tried running "opcontrol --start" (after previously running
>> "opcontrol --start-daemon") in dom0, I get this error message:
>> /usr/local/bin/opcontrol: line 1639: echo: write error: Operation not
>> permitted
>> and this message in the Xen console:
>> (XEN) xenoprof: operation 9 failed for dom 0 (status : -1)
>> It looks like opcontrol is trying to do this: echo 1 >
>> /dev/oprofile/enable
>> and it is failing. "operation 9" maps to XENOPROF_start which is
>> consistent with running "opcontrol --start." At first, I ignored the error
>> because it gave the indication "Profiler running" but after I ran "opcontrol
>> --shutdown" followed by "opreport" in dom0, I got this error message:
>> error: no sample files found: profile specification too strict ?
>> Do you know why the write error is occurring? I followed the steps in
>> xenoprof_tutorial.ppt.
>> Dante
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-devel

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>