This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] xenoprof: operation 9 failed for dom0 (status: -1)

To: Jose Renato Santos <joserenato.santos@xxxxxx>
Subject: [Xen-devel] xenoprof: operation 9 failed for dom0 (status: -1)
From: Dante Cinco <dantecinco@xxxxxxxxx>
Date: Thu, 5 Nov 2009 17:15:50 -0800
Cc: Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Thu, 05 Nov 2009 17:16:16 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:date:message-id:subject :from:to:cc:content-type; bh=0yMBh0diW3TXeRFTjmH/PFbrH9QMZIPaJ7ZyNcFHp6I=; b=QIi/9112yq7MZtKIgoI+B4aV9YeUDDxxKY757j9Dd39pecuPkUUdsxZl4w6Ph5oGd6 Ayk5v+u4z8jWVt2qePeTG8noO2wBltXqbYceNpm9Udwpu1KYU//iTmfSBufRy01ZvXDX 7Nnq4Dhx8xb54z+lE3Z91iXGGMOVcEyJvv314=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:cc:content-type; b=x4IqpXCnaPajj6DlwayIN2lpl/NLhdbXKhvOXLidknq4TvjrCJYiOCcf6H+nRuxFZC okKkdkIuypZrd1da68XavilIoOcfSW6ZJE27/ETFPvflDTPGPr9e7QfZSaSnYxdmizIq 5mSznkoKckOJIlDE45l0ZEux0LgfLJLZi1W6k=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx

When I tried running "opcontrol --start" (after previously running "opcontrol --start-daemon") in dom0, I get this error message:

/usr/local/bin/opcontrol: line 1639: echo: write error: Operation not permitted

and this message in the Xen console:

(XEN) xenoprof: operation 9 failed for dom 0 (status : -1)

It looks like opcontrol is trying to do this: echo 1 > /dev/oprofile/enable

and it is failing. "operation 9" maps to XENOPROF_start which is consistent with running "opcontrol --start." At first, I ignored the error because it gave the indication "Profiler running" but after I ran "opcontrol --shutdown" followed by "opreport" in dom0, I got this error message:

error: no sample files found: profile specification too strict ?

Do you know why the write error is occurring? I followed the steps in xenoprof_tutorial.ppt.

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>