This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Re: [ANNOUNCE] virtbench now has xen support

To: Rusty Russell <rusty@xxxxxxxxxxxxxxx>
Subject: [Xen-devel] Re: [ANNOUNCE] virtbench now has xen support
From: Jan Michael <jan.michael@xxxxxxx>
Date: Fri, 18 May 2007 19:56:50 +0200
Cc: Anthony Liguori <aliguori@xxxxxxxxxx>, Xen Mailing List <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Fri, 18 May 2007 10:55:20 -0700
Domainkey-signature: a=rsa-sha1; c=nofws; s=beta; d=cern.ch; q=dns; h=received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding; b=HrUdhXWTm5xodrM2I3khfO1qDwDOegEOXGCy+yo1DsLfYJ28jB5084VY7IyKVoUAB597p4+j+UwLUFgYvQ1ciNbAXOmNuMMXQ+B2QJlBn7s109Fk9WflLPQVF/JikkKs;
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <1179489064.17608.47.camel@xxxxxxxxxxxxxxxxxxxxx>
Keywords: CERN SpamKiller Note: -51 Charset: west-latin
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <1179196706.27304.22.camel@xxxxxxxxxxxxxxxxxxxxx> <B8C22E46-2962-4702-A4DF-7A02CC576F5E@xxxxxxx> <464A0F01.5030900@xxxxxxxxxx> <B560AF89-CB82-4842-8B36-E2216A0D319D@xxxxxxx> <1179489064.17608.47.camel@xxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Hi Rusty,

On 18.05.2007, at 13:51, Rusty Russell wrote:
On Fri, 2007-05-18 at 12:14 +0200, Jan Michael wrote:
Hi Anthony,

On 15.05.2007, at 21:50, Anthony Liguori wrote:
I've just pushed an update that should disable this test for older
versions of glibc.  Would appreciate if you let me know whether
this fixed your build.

That did the trick. Virtbench was sucessfully build on my system. I
was also able to run virtbench in local mode but when I tried to run
virtbench for xen I got the following error:

[root@lxdev19 virtbench-44dc217a9422]# KERNEL="/etc/xen/vmlinuz" ./
virtbench xen --progress
virtbench: Start command failed for xen

I already tried to investigate this error viewing the virtbench
logfile which I specified in SETTINGS file. But the logfile was not
created :-(.

This is a failure of the "xen/start" command.  I had this happen when
"/etc/init.d/xend restart" failed.  You can probably comment that line
out if you're already running Xen (perhaps xen's init scripts are

Now I'm one step further. The domUs will be created, but they are destroyed after seconds. I started one of them manually with console so that I could see the error message:

<boot error>
md: autorun ...
md: ... autorun DONE.
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown- block(1,0)
</boot error>

That must have been something to do with the kernel I'm using. I have to investigate (google) this. But if you can also help me in this case - you're welcome!



Xen-devel mailing list