This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] xen-2.0 20040910 problems

To: xen-devel@xxxxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] xen-2.0 20040910 problems
From: Peri Hankey <mpah@xxxxxxxxxxxxxx>
Date: Fri, 10 Sep 2004 11:02:08 +0000 (UTC)
Delivery-date: Sun, 12 Sep 2004 07:43:55 +0100
Envelope-to: steven.hand@xxxxxxxxxxxx
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
User-agent: Loom/3.14 (http://gmane.org/)

I have been experimenting with xen 2.0 and before that with xeno-unstable. It
has proved interesting and promising

However, the last few updates have been problematic. In particular it looks as
if the ext3 filesystem is not correctly handled.

I typically develop in the xen0 domain, connecting over ssh from a different

Recent history:

    20040907:  occasional kernel BUGs
    20040908:  instant reboot loop when booting xen
    20040909:  mysterious filesystem problems
    20040910:  mysterious filesystem problems

The main symptoms are:
rpm -qa

crashes with floating point exception or otherwise dies some way into 
generating a list of installed rpms. Looked like corruption of rpm database. 
The 'rpm --rebuilddb' operation also failed, so I was investigating ways of
reconstructing the database when I encountered other problems - eg: 

mv  bla* dirname

complained that the last argument was not a directory when it quite clearly was,
as in 'mkdir newdirectory; mv bla* newdirectory;'

Neither of these problems arise when I reboot the same system using my standard
kernel (2.6.7 compiled from source). In each case I am booting into the same
environment (mandrake 10.0 community + updates, running in init level 3).

I haven't tried with any other filesystem, but have tried using gcc versions
3.3.2 and 3.4.0.

I don't know if anyone else has encountered this kind of problem.

The kernel BUG problem looks as if it may be related to preemption in the
kernel. It occurred when I had dom0 + 6 domU systems running, and would happen
both in dom0 and in the domU systems. A typcial example:

------------[ cut here ]------------
kernel BUG at mm/rmap.c:251!
invalid operand: 0000 [#1]
Modules linked in:
CPU:    0
EIP:    0061:[<c0149ca9>]    Not tainted
EFLAGS: 00010246   (
EIP is at page_referenced+0x15e/0x175
eax: c2050000   ebx: c1119858   ecx: 00000f30   edx: c1c52480
esi: c1119840   edi: c1c52480   ebp: 00000000   esp: c2051e4c
ds: 0069   es: 0069   ss: 0069
Process kswapd0 (pid: 18, threadinfo=c2050000 task=c204b080)
Stack: c111e600 c18360cc c2051e6c 00000009 00000009 00000009 00000000 00000000
       00000001 c2050000 c02bc9c0 00000000 c013f387 c1119858 c1119840 c02bc9c0
       c2050000 c0141207 c1119840 c02bcb08 c02bc9dc 00000001 00000020 00000020
Call Trace:
 [<c013f387>] __pagevec_release+0x25/0x30
 [<c0141207>] refill_inactive_zone+0x591/0x662
 [<c013ffbc>] shrink_slab+0x98/0x1a9
 [<c014134a>] shrink_zone+0x72/0xb6
 [<c0141784>] balance_pgdat+0x1d4/0x2b1
 [<c0141920>] kswapd+0xbf/0xc1
 [<c011a245>] autoremove_wake_function+0x0/0x57
 [<c010d7c6>] ret_from_fork+0x6/0x14
 [<c011a245>] autoremove_wake_function+0x0/0x57
 [<c0141861>] kswapd+0x0/0xc1
 [<c010ee91>] kernel_thread_helper+0x5/0xb
Code: 0f 0b fb 00 c9 2a 29 c0 e9 08 ff ff ff e8 a0 c1 13 00 e9 53
 <6>note: kswapd0[18] exited with preempt_count 2
------------[ cut here ]------------

The following instance mentioned 'scheduling while atomic'. I can send more log
output if it would be useful - I was waiting to see if relevant-sounding
changesets had done the trick.

On a different topic, I have never yet seen the web interface work for long
enough to be useful - it always crashes with the int-text type clash that was
mentioned somewhere in the changelogs as having been fixed.

Peri Hankey

This SF.Net email is sponsored by: YOU BE THE JUDGE. Be one of 170
Project Admins to receive an Apple iPod Mini FREE for your judgement on
who ports your project to Linux PPC the best. Sponsored by IBM. 
Deadline: Sept. 13. Go here: http://sf.net/ppc_contest.php
Xen-devel mailing list