[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] loop devices

  • To: <xen-devel@xxxxxxxxxxxxxxxxxxx>
  • From: "Apparao, Padmashree K" <padmashree.k.apparao@xxxxxxxxx>
  • Date: Mon, 16 Oct 2006 16:14:44 -0700
  • Delivery-date: Mon, 16 Oct 2006 16:15:12 -0700
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>
  • Thread-index: AcbxeN2WjTjmTVOzQECkJGpYTAWN4A==
  • Thread-topic: loop devices



I have installed xen-unstable  change set 1150. I have 3 nics in my system.

My ifconfig  shows eth1, eth4 and eth5.


And a brctl show shows xenbr1 only.


When I try to create bridge 4

/etc/xen/scripts/network-bridge vifnum=4 start


Link veth4 is missing.

This may be because you have reached the limit of the number of interfaces

that the loopback driver supports.  If the loopback driver is a module, you

may raise this limit by passing it as a parameter (nloopbacks=<N>); if the

driver is compiled statically into the kernel, then you may set the parameter

using loopback.nloopbacks=<N> on the domain 0 kernel command line.



I tried increasing the loopback devices in the kernel boot command line using netloop.nloopbacks=64

And also with max_loop=64, but neither worked.


Does anyone have any ideas of what could be wrong?



- Padma


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.