This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] expanding img file

To: Paul Eskello <paul.eskello@xxxxxxxxx>
Subject: Re: [Xen-users] expanding img file
From: Alexis de BRUYN <alexis@xxxxxxxxxxx>
Date: Mon, 13 Apr 2009 23:22:43 +0200
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 13 Apr 2009 14:23:36 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <8cdf6c720904130854j109e2d4bq4f4bc9878b95e932@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <8cdf6c720904130854j109e2d4bq4f4bc9878b95e932@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Windows/20090302)
Hi Paul,

On Debian (Etch/Lenny), I've successfully expanded img files, several
times, with the following commands (from

Backup the File based image firstly, making sure it is not mounted nor
running as a xen domU.

dd if=/dev/zero of=file.img bs=1M conv=notrunc count=1 seek=2000
#This resizes the file.img to 2GB.
losetup /dev/loop1 file.img
#loop1 had to be used as xen was already running a different domU via loop0.
e2fsck -f /dev/loop1
resize2fs /dev/loop1
e2fsck -f /dev/loop1
losetup -d /dev/loop1

I am not really familiar with Centos, I hope this will work for you.

Best regards,

Paul Eskello a écrit :
> Hi,
> I use xen on centos 5.2 x86 and used virt-install to create a few
> virtual machines.
> A few days ago centos 5.3 emerged, but I did not allocate enough
> diskspace for these virtual machines, only 2 gb. That's way too small
> for running yum-upgrade.
> So I tried to increase them. With no luck. I found a howto that
> instructs me to mount -o loop /mnt /vm/foo.img, but that fails:
> "mount: you must specify the filesystem type" .
> Specifying ext2 says:
> "mount: wrong fs type, bad option, bad superblock on /dev/loop0,
>        missing codepage or other error
>        In some cases useful info is found in syslog - try
>        dmesg | tail  or so"
> In dmesg:
> "loop: loaded (max 8 devices)
> hfs: unable to find HFS+ superblock
> VFS: Can't find an ext2 filesystem on dev loop0."
> Another option I saw was just appending a gigabyte of /dev/zero using
> dd. I did that, but the diskspace in the virtual machine stays 2gb.
> I think I ran outta options.
> Any hints or advice ? Besides building new machines from scratch using
> the correct sizes ;-/
> Regards.
> P
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Alexis de BRUYN
email : alexis@xxxxxxxxxxx

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>