This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] expanding img file

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] expanding img file
From: Paul Eskello <paul.eskello@xxxxxxxxx>
Date: Mon, 13 Apr 2009 17:54:21 +0200
Delivery-date: Mon, 13 Apr 2009 08:55:05 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:date:message-id:subject :from:to:content-type:content-transfer-encoding; bh=wjaAEacwPVdRPbQ5zXEEKycObSBNysCo9XteIJJq5c4=; b=rYkG2BFJUHSPrf+VhqbyJ0yEWaLjXBIUHDNKe2QFlYKLy9kF+W3m7I8JKX9iYmFxfE rZ8ebKI6DgZS/T0XcIHX+C3oyIkakys7TZBSDr/yWy5PjNnUHcD4Iml+a7m96VxmRFaZ ZKFOFeRx6UxanXmOUDDhQrnBXpCeCnZ74Z0ko=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type :content-transfer-encoding; b=o3ixKDbFnZ0GbprOFNLTvhEngOYk7gKgsZMPY8XJURTdAC8VrzBw/YiHf6oqg7a3Fd zFXW6dECLA0QWRoLQcrJXw5UAfJX+CvOEy84oWwdFLstZLPFGjjASxryUhZbvuiK8f8F /CqwU2INPQBeuocxY1z8t2LiHPWBTB615Msqg=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

I use xen on centos 5.2 x86 and used virt-install to create a few
virtual machines.

A few days ago centos 5.3 emerged, but I did not allocate enough
diskspace for these virtual machines, only 2 gb. That's way too small
for running yum-upgrade.

So I tried to increase them. With no luck. I found a howto that
instructs me to mount -o loop /mnt /vm/foo.img, but that fails:
"mount: you must specify the filesystem type" .

Specifying ext2 says:
"mount: wrong fs type, bad option, bad superblock on /dev/loop0,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so"

In dmesg:
"loop: loaded (max 8 devices)
hfs: unable to find HFS+ superblock
VFS: Can't find an ext2 filesystem on dev loop0."

Another option I saw was just appending a gigabyte of /dev/zero using
dd. I did that, but the diskspace in the virtual machine stays 2gb.

I think I ran outta options.
Any hints or advice ? Besides building new machines from scratch using
the correct sizes ;-/


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>