This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Release 0.8.9 of GPL PV drivers for Windows

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Release 0.8.9 of GPL PV drivers for Windows
From: jim burns <jim_burn@xxxxxxxxxxxxx>
Date: Sun, 27 Apr 2008 03:16:09 -0400
Delivery-date: Sun, 27 Apr 2008 00:16:47 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <AEC6C66638C05B468B556EA548C1A77D013DC57C@trantor>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <AEC6C66638C05B468B556EA548C1A77D013DC578@trantor> <481348A6.8090200@xxxxxx> <AEC6C66638C05B468B556EA548C1A77D013DC57C@trantor> (sfid-20080426_221856_679345_9B1B4935)
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: KMail/1.9.9
On Saturday April 26 2008 10:12:33 pm James Harper wrote:
> Hmmm... uninstall.bat is a work in progress and probably shouldn't have
> been included. I suspect that if you rebooted after running
> uninstall.bat but before running install.bat you would have had an
> unbootable system.

Well, for the first time since 0.8.4, I got winxp to boot w/ /gplpv, using 
0.8.9. I booted w/o /gplpv and then ran uninstall.bat. Because of the warning 
above, I ran install.bat right away w/o a reboot. The final screen came up 
and said all drivers were updated except xennet, which was 'Ready to Use'. 
Then I rebooted w/ /gplpv, and the Find New Hardware Wizard came up 
automatically and guided me through installing xennet w/o a hitch.

I had previously disabled all the new features in Device Manager's Xen Net 
Device Driver Properties' Advanced Tab. (This was done by copying over the 
0.8.4 files so I could boot w/o a BSOD.) An 'iperf -c dom0-name -t 60' came 
up with 27.3 Mbits/s. I then proceeded to turn on each feature one at a time 
in the Advanced tab, and rebooting w/ /gplpv. Device Manager invariably hung 
after enabling each feature, which caused the reboot to hang. All 
measurements are with vcpus=2, unless noted otherwise.

After adding enabling Checksum Offload, iperf gave 30.5 Mb/s.

After adding setting 61440 for Large Send Offload, iperf gave 25.3 Mb/s.

After adding enabling Scatter/Gather, iperf gave 25.1 Mb/s.

So there are minor variations with and w/o the various options, but on the 
whole, much better than the last version I could test, 0.8.4.

From James' original post:
> From the testing I've done, on a UP windows DomU, with iperf options '-l
> 1M -w 1M', with the iperf server running in Dom0, I get TX throughput of
> about 1.5Gbits/second and RX throughput of about 0.5Gbits/second. When I
> tried it under SMP it worked, but the performance was horrible. Probably
> best if you don't run it under SMP for the moment :)

Doing 'iperf -c dom0-name -l 1M -w 1M' gives 28.8 Mb/s, and reversing the 
direction (winxp as iperf server) gives 30.2 Mb/s.

Going down to vcpu=1, dom0 as server gives 27.1 Mb/s, and domu as server gives 
35.7 Mb/s, so there is not a lot of difference between 1 and 2 vcpus for me.

Nice improvements. I will test disk i/o w/ iometer later.

Xen-users mailing list