This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Can't get template (domU) to work

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Can't get template (domU) to work
From: "Tito Valentin" <daemonracing@xxxxxxxxx>
Date: Sun, 6 Apr 2008 21:26:46 -0400
Delivery-date: Sun, 06 Apr 2008 18:27:22 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; bh=YAveo46iwo4XPKUx1coLQ9VY4klh4sRf8JU2EapBL1Y=; b=khU8t1Bskw3Tw7rKFg21oG8pESypo65cmqjMLllLMkXfvIz7dS8RiMj40domFXE9sC5Pg7FiKI6PGEtbCT8FS0jsgxQRlOtVjcamG/ejRzkyg7tthtLrzN0Oa6xfNp38A7+aA44XlpFC5gr/+B9zp/Iax8hgmog9t39z122C3Jk=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; b=Pe3do9Jhi4B3xbHwkSvnMTkelu+59McsPPislHobO9iKc79IqeI+xaJgd7FKb+HNczDShX6BMeIO67Bx9nbMgjxMsOe/Obag5lNYhTw8wM2efBd/bMN22zT6Kf9x8DV6FMj+1S7BkuItKIQ3+YwY0S4Dg5go/uncAJott07M6cY=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <200804062040.46374.mark.williamson@xxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <c5ffea430804051541k295672daidcee447bce9df483@xxxxxxxxxxxxxx> <200804062040.46374.mark.williamson@xxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

Thanks for your help here.  I am still battling this issue but based on the details that you have given me, is it safe to assume that I shouldn't be using a gentoo domU on a ubuntu dom0 system?

Is it best to be using templates/domU VM's that are based/alike as the dom0 itself?  For example, if I am running CentOS on my server, I should stick with CentOS domU's and nothing else?  And, if I want to run Gentoo domU's, then I should build another server running Gentoo to use gentoo domU's?  Just like now, I have Ubuntu Server running and trying to get gentoo domU but not working as stated.


On Sun, Apr 6, 2008 at 3:40 PM, Mark Williamson <mark.williamson@xxxxxxxxxxxx> wrote:
> /etc/xen/gentoo.2007-0.xen3.cfg
> /mnt/gentoo/gentoo.2007-0.img
> /mnt/gentoo/gentoo.swap
> Here is what my gentoo.2007-0.xen3.cfg looks like:
> root@personal:/etc/xen# cat /etc/xen/gentoo.2007-0.xen3.cfg
> kernel = "/boot/vmlinuz-2.6.22-14-xen"
> memory = 456
> name = "gentoo.2007-0"
> vif = [ '' ]
> dhcp = "dhcp"
> #disk = ['file:/mnt/gentoo/gentoo.2007-0.img,sda1,w',
> 'file:/mnt/gentoo/gentoo.swap,sda2,w']
> disk = ['tap:aio:/mnt/gentoo/gentoo.2007-0.img,xvda1,w',
> 'tap:aio:/mnt/gentoo/gentoo.swap,xvda2,w']
> root = "/dev/xvda1 ro"
> #initrd = "/boot/initrd.img-2.6.22-14-xen"
> extra = "gentoo=nodevfs"
> The problem is that everytime I do:
> root@personal:/etc/xen# xm create gentoo.2007-0.xen3.cfg -c
> I get:
> [ 6195.091118] List of all partitions:
> [ 6195.091146] ca01    2049024 xvda1 driver: vbd
> [ 6195.091157] ca02      65536 xvda2 driver: vbd
> [ 6195.091167] No filesystem could mount root, tried:  cramfs
> [ 6195.091179] Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(202,1)

It looks like it's trying to mount the root FS, it's trying the only
filesystem it can think of (which, apparently, is cramfs), it's failing to
mount and then it's giving up.

You're not using an initrd - presumably your kernel would normally load the
primary filesystem driver from the initrd so that it could mount the root

I'm not really clear what kernel you're supposed to be using with a jailtime
image but I guess you're currently using your Ubuntu kernel?  That might not
provide quite such a good Gentoo-like experience as using the Gentoo kernel.
Still, lets see if we can get things a bit further at least...

> That happens during the boot of the new domU.  I have tried to figure out
> if my problem was here in my gentoo*.cfg file:
> #disk = ['file:/mnt/gentoo/gentoo.2007-0.img,sda1,w',
> 'file:/mnt/gentoo/gentoo.swap,sda2,w']
> disk = ['tap:aio:/mnt/gentoo/gentoo.2007-0.img,xvda1,w',
> 'tap:aio:/mnt/gentoo/gentoo.swap,xvda2,w']
> root = "/dev/xvda1 ro"

That shouldn't be it, although tap:aio might work better in some

I think you need to get the initrd loading.  On my system the config file uses
the "ramdisk=" parameter rather than "initrd=".  Have you tried that?

> But I have nooooo luck.  I have looked online everywhere and through the
> mailing list to no avail.  Does anyone know why this could be happening?

It's definitely some kind of problem with mounting the root filesystem.  It's
fairly common these days for system boot to not work without an initrd, so I
guess the packagers might have decided to put the filesystem drivers into
that rather than building into the kernel.

Hope that helps,


Push Me Pull You - Distributed SCM tool (http://www.cl.cam.ac.uk/~maw48/pmpu/)

Xen-users mailing list