This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Re: Can't get template (domU) to work

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Re: Can't get template (domU) to work
From: "Tito Valentin" <daemonracing@xxxxxxxxx>
Date: Sun, 6 Apr 2008 14:55:58 -0400
Delivery-date: Sun, 06 Apr 2008 11:56:34 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; bh=TzRIGhg5bXVGJZKFS8iGfU5PeDj/TUH6ONIQSdFvq2c=; b=DdpaHdY4HjdJl7wfrgEjWZlRtTcKmzfHsoUexL7ZUmG0lEqWEfcn2DkIZxHLtFemYTcpblSm4/Sx9oWTCgr3faYgjEOAON1fduiM5FmyBTGBQ0e2FMNOIaGaTxYLLv3/pHeUQKnGv4tUBSBTQVrFa6eTn4v5e+BlBA8GwUHaTow=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; b=aAJgVh9t1cUPpnorujOHEWSoOLj50Dpe0P4uUvTyMpfRFHplJlIghnYwdIgLQtnj6Q9SjjsPvZIdHTQViLpkAhO2688QjRcvyRhth6aTSn0IZ4Tq8QpHo9uVCWwt/ggN845cluEOZFQovLkZWw6cE5U4z28Cl9iqBrU9FR/SYuM=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <1e16a9ed0804061115w430ade71g45b99d0d6027d644@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <c5ffea430804051541k295672daidcee447bce9df483@xxxxxxxxxxxxxx> <c5ffea430804060840q1c9ae3a0r726a2103c9d7498e@xxxxxxxxxxxxxx> <1e16a9ed0804061115w430ade71g45b99d0d6027d644@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

Thanks for the reply.  Yes, I have looked through the docs at gentoo and can't find anything regarding modifying the kernel.  The thing is that this is a template from jailtime.org and I should not have to modify anything in the kernel.  It comes complete with *.img, *.cfg and *.swap.  All I should have to do is edit *.cfg to get the system booted but apparently that doesn't work :-(

On Sun, Apr 6, 2008 at 2:15 PM, Todd Deshane <deshantm@xxxxxxxxx> wrote:
Hi Tito,

On Sun, Apr 6, 2008 at 11:40 AM, Tito Valentin <daemonracing@xxxxxxxxx> wrote:
Hello, could anyone please provide some pointers here?

Have you looked through: http://gentoo-wiki.com/HOWTO_Xen_and_Gentoo ?

My guess is that you are missing something in the kernel or initrd, or that your configuration is a little off. It has been quite awhile since I have used gentoo, so i don't have a clear recollection of what the problem is.



Thanks again

On Sat, Apr 5, 2008 at 6:41 PM, Tito Valentin <daemonracing@xxxxxxxxx> wrote:
Hello All,

I have been having a very difficult time getting any template to work on xen.  Here is what I am running

root@personal:/etc/xen-tools# xm info
host                   : personal
release                : 2.6.22-14-xen
version                : #1 SMP Tue Feb 12 09:27:26 UTC 2008
machine                : i686
nr_cpus                : 2
nr_nodes               : 1
sockets_per_node       : 1
cores_per_socket       : 1
threads_per_core       : 2
cpu_mhz                : 3059
hw_caps                : bfebfbff:00000000:00000000:00000080:00004400
total_memory           : 2046
free_memory            : 456
xen_major              : 3
xen_minor              : 1
xen_extra              : .0
xen_caps               : xen-3.0-x86_32p
xen_scheduler          : credit
xen_pagesize           : 4096
platform_params        : virt_start=0xf5800000
xen_changeset          : unavailable
cc_compiler            : gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2
cc_compile_by          : buildd
cc_compile_domain      : buildd
cc_compile_date        : Fri Oct 12 15:08:23 GMT 2007
xend_config_format     : 4

Now, I have these three files:


Here is what my gentoo.2007-0.xen3.cfg looks like:

root@personal:/etc/xen# cat /etc/xen/gentoo.2007-0.xen3.cfg
kernel = "/boot/vmlinuz-2.6.22-14-xen"
memory = 456
name = "gentoo.2007-0"
vif = [ '' ]
dhcp = "dhcp"
#disk = ['file:/mnt/gentoo/gentoo.2007-0.img,sda1,w', 'file:/mnt/gentoo/gentoo.swap,sda2,w']
disk = ['tap:aio:/mnt/gentoo/gentoo.2007-0.img,xvda1,w', 'tap:aio:/mnt/gentoo/gentoo.swap,xvda2,w']
root = "/dev/xvda1 ro"
#initrd = "/boot/initrd.img-2.6.22-14-xen"
extra = "gentoo=nodevfs"

The problem is that everytime I do:

root@personal:/etc/xen# xm create gentoo.2007-0.xen3.cfg -c

I get:

[ 6195.091118] List of all partitions:
[ 6195.091146] ca01    2049024 xvda1 driver: vbd
[ 6195.091157] ca02      65536 xvda2 driver: vbd
[ 6195.091167] No filesystem could mount root, tried:  cramfs
[ 6195.091179] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(202,1)

That happens during the boot of the new domU.  I have tried to figure out if my problem was here in my gentoo*.cfg file:

#disk = ['file:/mnt/gentoo/gentoo.2007-0.img,sda1,w', 'file:/mnt/gentoo/gentoo.swap,sda2,w']
disk = ['tap:aio:/mnt/gentoo/gentoo.2007-0.img,xvda1,w', 'tap:aio:/mnt/gentoo/gentoo.swap,xvda2,w']
root = "/dev/xvda1 ro"

But I have nooooo luck.  I have looked online everywhere and through the mailing list to no avail.  Does anyone know why this could be happening?


Xen-users mailing list

Xen-users mailing list