This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Can't get template (domU) to work

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Can't get template (domU) to work
From: Mark Williamson <mark.williamson@xxxxxxxxxxxx>
Date: Sun, 6 Apr 2008 20:40:44 +0100
Cc: Tito Valentin <daemonracing@xxxxxxxxx>
Delivery-date: Sun, 06 Apr 2008 12:41:24 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <c5ffea430804051541k295672daidcee447bce9df483@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <c5ffea430804051541k295672daidcee447bce9df483@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: KMail/1.9.6 (enterprise 0.20070907.709405)
> /etc/xen/gentoo.2007-0.xen3.cfg
> /mnt/gentoo/gentoo.2007-0.img
> /mnt/gentoo/gentoo.swap
> Here is what my gentoo.2007-0.xen3.cfg looks like:
> root@personal:/etc/xen# cat /etc/xen/gentoo.2007-0.xen3.cfg
> kernel = "/boot/vmlinuz-2.6.22-14-xen"
> memory = 456
> name = "gentoo.2007-0"
> vif = [ '' ]
> dhcp = "dhcp"
> #disk = ['file:/mnt/gentoo/gentoo.2007-0.img,sda1,w',
> 'file:/mnt/gentoo/gentoo.swap,sda2,w']
> disk = ['tap:aio:/mnt/gentoo/gentoo.2007-0.img,xvda1,w',
> 'tap:aio:/mnt/gentoo/gentoo.swap,xvda2,w']
> root = "/dev/xvda1 ro"
> #initrd = "/boot/initrd.img-2.6.22-14-xen"
> extra = "gentoo=nodevfs"
> The problem is that everytime I do:
> root@personal:/etc/xen# xm create gentoo.2007-0.xen3.cfg -c
> I get:
> [ 6195.091118] List of all partitions:
> [ 6195.091146] ca01    2049024 xvda1 driver: vbd
> [ 6195.091157] ca02      65536 xvda2 driver: vbd
> [ 6195.091167] No filesystem could mount root, tried:  cramfs
> [ 6195.091179] Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(202,1)

It looks like it's trying to mount the root FS, it's trying the only 
filesystem it can think of (which, apparently, is cramfs), it's failing to 
mount and then it's giving up.

You're not using an initrd - presumably your kernel would normally load the 
primary filesystem driver from the initrd so that it could mount the root 

I'm not really clear what kernel you're supposed to be using with a jailtime 
image but I guess you're currently using your Ubuntu kernel?  That might not 
provide quite such a good Gentoo-like experience as using the Gentoo kernel.  
Still, lets see if we can get things a bit further at least...

> That happens during the boot of the new domU.  I have tried to figure out
> if my problem was here in my gentoo*.cfg file:
> #disk = ['file:/mnt/gentoo/gentoo.2007-0.img,sda1,w',
> 'file:/mnt/gentoo/gentoo.swap,sda2,w']
> disk = ['tap:aio:/mnt/gentoo/gentoo.2007-0.img,xvda1,w',
> 'tap:aio:/mnt/gentoo/gentoo.swap,xvda2,w']
> root = "/dev/xvda1 ro"

That shouldn't be it, although tap:aio might work better in some 

I think you need to get the initrd loading.  On my system the config file uses 
the "ramdisk=" parameter rather than "initrd=".  Have you tried that?

> But I have nooooo luck.  I have looked online everywhere and through the
> mailing list to no avail.  Does anyone know why this could be happening?

It's definitely some kind of problem with mounting the root filesystem.  It's 
fairly common these days for system boot to not work without an initrd, so I 
guess the packagers might have decided to put the filesystem drivers into 
that rather than building into the kernel.

Hope that helps,


Push Me Pull You - Distributed SCM tool (http://www.cl.cam.ac.uk/~maw48/pmpu/)

Xen-users mailing list