This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Me vs. RHEL 2.6.18-53.1.4.el5xen

Steven Timm wrote:
On the first try of changing the xen.cfg to use xvda rather than
sda, I forgot to change the "root" clause to also point to xvda.
Now my domain is up under el5xen kernel but it has no network--

add "alias eth0 xennet" in /etc/modprobe.conf and reboot.

nevertheless this is progress.

Still, does anyone know--under red hat should I be using the .el5xen
or the .el5PAE kernel for the guest?

The former.



Steve Timm

On Wed, 12 Dec 2007, Steven Timm wrote:

On Wed, 12 Dec 2007, Sadique Puthen wrote:

How did you create your initrd image?

Recreate it using --preload=xenblk --with-xennet. Change the disk line as below.

disk = [ 'phy:LG0/LV1,xvda,w','phy:LG0/LV2,xvdb,w','phy:LG0/LV3,xvdc,w' ]

Then try to start the guest.


I did not have these options in the initial initrd.  I remade the
initrd for 2.6.18-53.1.4.el5xen and got the same error as before,
it couldn't find the /dev/root.

Should I have done the 2.6.18-53.1.4.el5PAE kernel instead?

Does it matter that I am doing the mkinitrd while in chroot
to a 32-bit distro, but still actually running a 64-bit kernel?
Is the 3ware controller a problem here? (I presume that I was supposed to change the /etc/fstab of the
FS of the xen instance as well, I did so).

I tried to change the other .cfg file with the older
xensource kernel to use xvda, xvdb, etc and now that won't start
either.  I get the error "device xvda (51712,vbd) is already connected),
due, no doubt, to earlier things which tried to use the device
crashing and not closing it properly.  Any way to get around that?


Steve Timm

Steven Timm wrote:
<flxi05> grep -v ^# xen1.cfg

kernel = "/linux32/boot/vmlinuz-2.6.18-53.1.4.el5xen"
ramdisk = "/linux32/boot/initrd-2.6.18-53.1.4.el5xen.img"
memory = 4000
name = "fcdfx41"
vif = [ 'mac=00:16:3e:0C:04:01, bridge=xenbr0', 'mac=00:16:3e:0C:04:09, bridge=xenbr1' ] disk = [ 'phy:LG0/LV1,sda1,w','phy:LG0/LV2,sda2,w','phy:LG0/LV3,sda3,w' ]
netmask= ""
gateway= ""
hostname= "fcdfx41.fnal.gov"
root = "/dev/sda1 ro"
extra = "4"

I am using the kernel inside dom0 to try to boot the domU.  That is
what I have done on all my installations up until now. But I am willing
to change if someone finds a better way.

I also tried to install a different Xen instance from scratch using
virt-manager, but it did get up to installing about ten rpms before it
quit, i.e. it got through the whole anaconda input phase of the install.

Steve Timm

Steven C. Timm, Ph.D  (630) 840-8525
timm@xxxxxxxx  http://home.fnal.gov/~timm/
Fermilab Computing Division, Scientific Computing Facilities,
Grid Facilities Department, FermiGrid Services Group, Assistant Group Leader.

On Wed, 12 Dec 2007, Sadique Puthen wrote:

Can you please show your guest configuration file? Are you using a kernel and ramdisk from the dom0 to boot the guest or are they put inside guest filesystem and using pygrub to load them from guest?


Steven Timm wrote:

I am trying to migrate an existing working xen setup
which was based on xen 3.1.0 tarballs as they were available
at xen.org.  Underlying distro is RHEL5.
I am now trying to use the not-really-xen3.1.0-but-almost
xen that comes with RHEL5 update 1.

Host was 64-bit dom0. first domU was PAE 32-bit, both from xen 3.1.0 tarballs.

Now I have installed kernel-2.6.18-53.1.4.el5xen on the dom0.
That boots up fine.  I tried to start up the domU first with
the old 2.6.18-xen kernel (32-bit PAE) that was working before. That
also started up OK, although it did crash once.

The question is--how to get the 32-bit PAE kernel from
RedHAt installed and booting in the domU.  I tried both
2.6.18-53.1.4.el5xen (32bit) and 2.6.18-53.1.4.el5PAE (32bit)

the former cannot find the root system file system of the domU. I get the following error:

mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init

If I compare between the 2.6.18-xen kernel from xensource which
works, and this one that doesn't, I see that I am missing
the modules ide-disk.ko, libusual.ko, usbcore.ko, usb-storage.ko
The usb modules should be irrelevant since there is no usb on this machine. alas, the ide-disk.ko module which seems to be the key one isn't even
there at all in the redhat ersion of the kernel.


If I try to load the PAE version of the kernel instead, I get the following error message:

VmError: (2, 'Invalid kernel', 'xc_dom_parse_elf_kernel: ELF image has no shstrtab\n')

Any clue what may be going on?
Does anyone else have a RHEL 5 update 1 system working with 64-bit host,
32 bit PAE guests?


Steve Timm

Xen-users mailing list

Xen-users mailing list