This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Me vs. RHEL 2.6.18-53.1.4.el5xen

To: Steven Timm <timm@xxxxxxxx>
Subject: Re: [Xen-users] Me vs. RHEL 2.6.18-53.1.4.el5xen
From: Sadique Puthen <sputhenp@xxxxxxxxxx>
Date: Wed, 12 Dec 2007 11:17:25 +0530
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Tue, 11 Dec 2007 21:47:59 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <Pine.LNX.4.64.0712111520410.7580@xxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <Pine.LNX.4.64.0712111520410.7580@xxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20070926)

Can you please show your guest configuration file? Are you using a kernel and ramdisk from the dom0 to boot the guest or are they put inside guest filesystem and using pygrub to load them from guest?


Steven Timm wrote:

I am trying to migrate an existing working xen setup
which was based on xen 3.1.0 tarballs as they were available
at xen.org.  Underlying distro is RHEL5.
I am now trying to use the not-really-xen3.1.0-but-almost
xen that comes with RHEL5 update 1.

Host was 64-bit dom0. first domU was PAE 32-bit, both from xen 3.1.0 tarballs.

Now I have installed kernel-2.6.18-53.1.4.el5xen on the dom0.
That boots up fine.  I tried to start up the domU first with
the old 2.6.18-xen kernel (32-bit PAE) that was working before.  That
also started up OK, although it did crash once.

The question is--how to get the 32-bit PAE kernel from
RedHAt installed and booting in the domU.  I tried both
2.6.18-53.1.4.el5xen (32bit) and 2.6.18-53.1.4.el5PAE (32bit)

the former cannot find the root system file system of the domU. I get the following error:

mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init

If I compare between the 2.6.18-xen kernel from xensource which
works, and this one that doesn't, I see that I am missing
the modules ide-disk.ko, libusual.ko, usbcore.ko, usb-storage.ko
The usb modules should be irrelevant since there is no usb on this machine.
alas, the ide-disk.ko module which seems to be the key one isn't even
there at all in the redhat ersion of the kernel.


If I try to load the PAE version of the kernel instead, I get the following error message:

VmError: (2, 'Invalid kernel', 'xc_dom_parse_elf_kernel: ELF image has no shstrtab\n')

Any clue what may be going on?
Does anyone else have a RHEL 5 update 1 system working with 64-bit host,
32 bit PAE guests?


Steve Timm

Xen-users mailing list