This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] "'Invalid kernel', 'xc_dom_find_loader: no loader found\

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] "'Invalid kernel', 'xc_dom_find_loader: no loader found\n" with new vanilla 2.6.23-rc8
From: Mark Williamson <mark.williamson@xxxxxxxxxxxx>
Date: Sat, 6 Oct 2007 22:03:38 +0100
Cc: Nico Prenzel <nico.prenzel@xxxxxxxxxxxxx>
Delivery-date: Sat, 06 Oct 2007 14:04:28 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <OFAF6969B7.A5C7DC2A-ONC125725F.005674DA-C125725F.00567A70@xxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <OFAF6969B7.A5C7DC2A-ONC125725F.005674DA-C125725F.00567A70@xxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: KMail/1.9.6
Hmmmmm.  That sounds rather strange.  Have you tried booting the raw vmlinux 
rather than vmlinuz?  I don't think that ought to help, but I can't think of 
anything else right now!

Everything you've done looks right.  The classic mistake is to try and boot a 
Linux bzImage with the domain builder - which produces similar errors to what 
you have seen.  But it looks like you're just using the raw vmlinuz file from 
the kernel build, right?  In which case I'd say it *should* work...

What version of Xen are you running?  Can you stick the kernel online 
somewhere so others can have a go at booting it on their systems?


On Wednesday 10 January 2007, Nico Prenzel wrote:
> Hey folks,
> this is my first contact to XEN-users list. So please be patient if I
> missed something. I've searched a lot before writing this email.
> My problem:
> I do have a non-VT/Pacifica box (an old IBM Laptop). There I've got already
> Xen installed (Dom0, 2.6.18-xen0). Now I've tried to use the newest vanilla
> kernel from Kernel.org (at this time: 2.6.23-rc8). As commonly known this
> Kernel now does include the DomU patches needed to run this kernel as DomU
> under Dom0.
> So, I've compiled the 2.6.23-rc8 with the XEN specific settings, stated
> somewhere at user or devel list (i'll include all my config settings to
> this email) and tried to start my newly compiled and created xen-domain.
> But I do get the following error after issuing: xm create
> /etc/xen/szpn0005.intern.pn-systeme.de.cfg -c
> Using config file "/etc/xen/szpn0005.intern.pn-systeme.de.cfg".
> Error: (2, 'Invalid kernel', 'xc_dom_find_loader: no loader found\n')
> The first time I tried to build an DomU from the same kernel sources used
> for the Dom0. At this time all went fine and the DomU went up fine. So my
> general procedure could not be totaly wrong.
> So, what need to be done to run the new 2.6.23.* as DomU at top of default
> Dom0?
> PS: I'll attach all xen-logs/configs and kernel configs that could make
> sense.
> Thanks & Greetings.
> NicoP.
> (See attached file: xend-debug.log)(See attached file:
> config-2.6.18-xen0PN-Systeme)(See attached file:
> config-2.6.23-rc8PN-Systeme)(See attached file: domain-builder-ng.log)(See
> attached file: szpn0005.intern.pn-systeme.de.cfg)(See attached file:
> szpn0005.intern.pn-systeme.de.log)(See attached file: xend.log)

Dave: Just a question. What use is a unicyle with no seat?  And no pedals!
Mark: To answer a question with a question: What use is a skateboard?
Dave: Skateboards have wheels.
Mark: My wheel has a wheel!

Xen-users mailing list