This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Hypervisor does not start?

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Hypervisor does not start?
From: Mark Williamson <mark.williamson@xxxxxxxxxxxx>
Date: Sat, 6 Oct 2007 21:52:10 +0100
Cc: Andre Rupprich <info@xxxxxxxxxxxx>
Delivery-date: Sat, 06 Oct 2007 13:53:08 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <47011C08.5060609@xxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <47011C08.5060609@xxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: KMail/1.9.6
> I have a curious problem:
> a few month ago i set up a root server located at my provider. This
> server has a serial console so that I can see the boot messages.
> Last week I had to reboot the server and it does not start again! 

Maybe some kind of update whilst the machine was up has broken the 

> After 
> a few tries I initialized it with a new, fresh Debian, compiled Xen 3.1
> and used the old kernel-config. The config of the kernel which worked.
> The server does not start with the new kernel! But there is no message
> like "kernel panic - can't mount root fs" or something else. There's
> only the menu from grub, a message that it begins to boot but not any
> more. I think the Hypervisor itself does not start?!

Can we see your menu.lst?

> But why? 
> I tried older versions from Xen but with the same result.
> When I mount the harddiscs with a rescue-system I can't find any log
> entries. A non-xen kernel boots without any problems.


Are you sure it's not just something basic? (e.g. you forgot to configure Xen 
in menu.lst to output to the serial console, and so you're not getting any 
messages from it)

> Is it possible that one of the two processors has a damage? Possibly Xen
> calls functions of the processor which a non-xen kernel does not use?
> The next days  I will run a memory check to except the RAM as a cause...

I suspect it's a software change or a configuration problem rather than 
anything the matter with your hardware.


Dave: Just a question. What use is a unicyle with no seat?  And no pedals!
Mark: To answer a question with a question: What use is a skateboard?
Dave: Skateboards have wheels.
Mark: My wheel has a wheel!

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>