This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] "'Invalid kernel', 'xc_dom_find_loader: no loader found\n" w

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] "'Invalid kernel', 'xc_dom_find_loader: no loader found\n" with new vanilla 2.6.23-rc8
From: Nico Prenzel <nico.prenzel@xxxxxxxxxxxxx>
Date: Mon, 1 Oct 2007 17:26:25 +0200
Delivery-date: Mon, 01 Oct 2007 10:10:47 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
Importance: Normal
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

Hey folks,
this is my first contact to XEN-users list. So please be patient if I missed something. I've searched a lot before writing this email.

My problem:
I do have a non-VT/Pacifica box (an old IBM Laptop). There I've got already Xen installed (Dom0, 2.6.18-xen0). Now I've tried to use the newest vanilla kernel from Kernel.org (at this time: 2.6.23-rc8). As commonly known this Kernel now does include the DomU patches needed to run this kernel as DomU under Dom0.
So, I've compiled the 2.6.23-rc8 with the XEN specific settings, stated somewhere at user or devel list (i'll include all my config settings to this email) and tried to start my newly compiled and created xen-domain.

But I do get the following error after issuing: xm create /etc/xen/szpn0005.intern.pn-systeme.de.cfg -c
Using config file "/etc/xen/szpn0005.intern.pn-systeme.de.cfg".
Error: (2, 'Invalid kernel', 'xc_dom_find_loader: no loader found\n')

The first time I tried to build an DomU from the same kernel sources used for the Dom0. At this time all went fine and the DomU went up fine. So my general procedure could not be totaly wrong.

So, what need to be done to run the new 2.6.23.* as DomU at top of default Dom0?

PS: I'll attach all xen-logs/configs and kernel configs that could make sense.

Thanks & Greetings.

Attachment: xend-debug.log
Description: Binary data

Attachment: config-2.6.18-xen0PN-Systeme
Description: Binary data

Attachment: config-2.6.23-rc8PN-Systeme
Description: Binary data

Attachment: domain-builder-ng.log
Description: Binary data

Attachment: szpn0005.intern.pn-systeme.de.cfg
Description: Binary data

Attachment: szpn0005.intern.pn-systeme.de.log
Description: Binary data

Attachment: xend.log
Description: Binary data

Xen-users mailing list