This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] USB disk corruption on Xen 4.1.0 & Linux

To: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Subject: Re: [Xen-devel] USB disk corruption on Xen 4.1.0 & Linux
From: Anthony Wright <anthony@xxxxxxxxxxxxxxx>
Date: Thu, 02 Jun 2011 16:59:12 +0100
Cc: Ian Pratt <Ian.Pratt@xxxxxxxxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 02 Jun 2011 09:02:35 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20110602144411.GA31559@xxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20110601142349.GD4081@xxxxxxxxxxxx> <19639651.14.1307017496558.JavaMail.root@xxxxxxxxxxxxxxxxxxxxxx> <20110602143807.GA31439@xxxxxxxxxxxx> <20110602144411.GA31559@xxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv: Gecko/20110414 Thunderbird/3.1.10
On 02/06/2011 15:44, Konrad Rzeszutek Wilk wrote:
> On Thu, Jun 02, 2011 at 10:38:07AM -0400, Konrad Rzeszutek Wilk wrote:
>> On Thu, Jun 02, 2011 at 01:24:56PM +0100, Anthony Wright wrote:
>>>> Do you get the same problem if you boot baremetal and do 'iommu=soft' 
>>>> (without the mem=4G)? You should see the same error.
>>> I'm not quite sure what you mean by "boot baremetal", but I've just done a 
>>> boot where I removed the mem=4096M options from the Xen boot line and added 
>>> an 'iommu=soft' option. The result of this was a corrupt USB device again.
>> Baremetal = no Xen.
Tried a baremetal boot (no Xen) with ''iommu=soft" on the linux command
line, and the USB reads fine.
> I've an BIOSTART motherboard that looks to have a similar EHCI controller - 
> MCP61 based.
> Is the USB stick that you are using any special? Or is just a normal one?
It's a Kingston DataTraveler G2 (2GB). It's the cheapest memory stick I
could find at the time, nothing special as far as I know.

I'll try to get the kernel sorted out to get around the screen
corruption tonight, and try on another system tomorrow and with a
different memory stick too.



Xen-devel mailing list