This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] USB disk corruption on Xen 4.1.0 & Linux

To: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>, Ian.Pratt@xxxxxxxxxxxxx
Subject: Re: [Xen-devel] USB disk corruption on Xen 4.1.0 & Linux
From: Anthony Wright <anthony@xxxxxxxxxxxxxxx>
Date: Wed, 1 Jun 2011 10:52:50 +0100 (BST)
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 01 Jun 2011 03:10:12 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20110531145409.GN14641@xxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
On 31/05/2011 15:54, Konrad Rzeszutek Wilk wrote:
> Ok.. Had you tried my #devel/next-2.6.38 branch in the past?

Yes I tried one of your devel kernels in the past, but switched back to stock 
linux when I realised that Dom0 functionality was now in that. I'm willing to 
give a devel kernel a go if you think it would help.

> So this is from dom0 kernel, right?

The corruption occurs in the Dom0 kernel.

> What is the filesystem on the USB disk?

The filesystem on the USB disk is ext2. It's a slightly funny format because 
while the memory stick is a 2GB memory stick, it's partitioned and formatted as 
a 64MB memory stick. I've done an md5sum on the raw /dev/sdX device under a 
system that works and under a system that's faulty and I get different results, 
so I suspect the fault's below the file system.

> <sigh>Please provide serial log or dmesg output.

dmesg output is attached, but it doesn't show anything that I can see (I boot 
off a CD and then mount the USB memory stick - the fsck errors at the end)

On 01/06/2011 09:53, Ian Pratt wrote:
> Does the issue go away if you limit the total amount of memory visible to xen 
> to 4GB? (mem=4096M on the xen command line)
> If so, I suspect this is a swiotlb or latent UHCI driver issue. The easiest 
> way of working around it is just to ensure all > dom0 memory gets allocated 
> below 4GB, but it would be good to investigate properly.

Yes! I put mem=4096M on the xen command line as asked and everything starts 
working as it should yea!


Attachment: dmesg
Description: Binary data

Xen-devel mailing list