This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] USB disk corruption on Xen 4.1.0 & Linux

To: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Subject: Re: [Xen-devel] USB disk corruption on Xen 4.1.0 & Linux
From: Anthony Wright <anthony@xxxxxxxxxxxxxxx>
Date: Fri, 17 Jun 2011 10:45:41 +0100
Cc: Ian Pratt <Ian.Pratt@xxxxxxxxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 17 Jun 2011 02:46:59 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20110616201024.GA1184@xxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20110613220625.GB23755@xxxxxxxxxxxx> <30260355.6.1308134733567.JavaMail.root@xxxxxxxxxxxxxxxxxxxxxx> <20110616201024.GA1184@xxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv: Gecko/20110414 Thunderbird/3.1.10
On 16/06/2011 21:10, Konrad Rzeszutek Wilk wrote:
> So a couple of things popped at when looking at this:
> a). "sata_nv 0000:00:08.1: BMDMA: failed to set dma mask, falling back to PIO"
> That is not good. Somehow it wasn't able to set a 32-bit mask. Don't know
> if that is due to the driver or just that the kernel can't do it (b/c it
> was compiled with some special options).
I never saw anything in dmesg or any other logs.
> b). Are you using some special .config option? If you were to use a normal
>  distro would you see this?
My config is attached.
> c). You are using a 32-bit dom0. Didn't notice it until now so I wonder
>   if there are some lingering issues (for example not flushing the highmemory
>   mappings) that are at foot. Had you tried a 64-bit kernel before?
I haven't tried 64 bit because I need a 32 bit kernel.
> d). Does the problem exist if you try it with a 2.6.39 kernel or the 3.0-rc3?
It happens on every kernel I've tried which is 2.6.39, 2.6.39.x & 3.0-rc3
> e). Can you run lspci -n ? There is a pretty big file in 
> drivers/usb/host/pci-quirks.c
>   Want to check against your machine.
I have the problem on two machines and have attached the lspci -n for
both of them.

Attachment: config
Description: Text document

Attachment: lspci-n-machine1
Description: Text document

Attachment: lspci-n-machine2
Description: Text document

Xen-devel mailing list