This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] [SPAM] Re: kernel BUG at arch/x86/xen/mmu.c:1860!

To: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] [SPAM] Re: kernel BUG at arch/x86/xen/mmu.c:1860!
From: Andreas Olsowski <andreas.olsowski@xxxxxxxxxxx>
Date: Wed, 09 Mar 2011 20:59:06 +0100
Delivery-date: Fri, 11 Mar 2011 09:46:15 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20110309150023.GB6247@xxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20110303221639.GB12175@xxxxxxxxxxxx> <AANLkTi=r+ErO+PkPWF=3L8+v9+TPbgVz-6qaycTgMo4c@xxxxxxxxxxxxxx> <AANLkTimTuXqoLe9VinpAdhwJPO3Z8HGU2+KOoHOBaUvq@xxxxxxxxxxxxxx> <AANLkTimin0OZZUmvUr2KcXugc_2GGuEhRHLdug1ufha6@xxxxxxxxxxxxxx> <20110308192950.GA4562@xxxxxxxxxxxx> <20110308201002.GA5721@xxxxxxxxxxxx> <AANLkTikdA0vnxYzU7MFZNk3m6SH6=ns-WGVry2zCfws+@xxxxxxxxxxxxxx> <1299617407852-3414620.post@xxxxxxxxxxxxx> <20110309004318.GB10007@xxxxxxxxxxxx> <4D77251F.8070709@xxxxxxxxxxx> <20110309150023.GB6247@xxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20101226 Icedove/3.0.11
> That is interesting data. Can you give more details on what 2.6.31 kernel
> and hypervisor you are using? Have you tried to rev the hypervisor
> up to Xen 4.1.0-rc7-pre for example?
I can do you one more, here are links to, kernel tarball as built by me (, its configuration and my xen4.0.0 directory.

Tomorrow i will test 4.1.0 and 2.6.38, allthough i have to say, if one kernel works and the other doesnt, to me it seems like a kernel problem, not one of the hypervisor. Of course, since i dont know the inner workings of xen, that point of view might be ... flawed.

It would be nice if you could define a set of parameters that could prove beneficial in provoking the bug as it would make it easier for me to test different scenarios. Or better yet a script that definitly will provoke it within a given timeframe.

So far even restarting multipathd _could_ trigger it for me.
It also occured during bootup and when it did it kept on happening until i did a cold restart of the server. Does that make sense? Does data remain in the memory modules when i reboot a system? (init 6) And if that is so, whats the "Scrubbing memory ....." for that i see when xen is loading?

One thing i would like to verify is that the bug only occurs when running the kernel under xen and not when its running on its own.
I cant quite remember if i tried that in 2010.

Today i ran a loop of 300 lvcreate,snapshot,lvdelete on a standalone 2.6.32-xen0 kernel and did not receive an error. I didnt really have the time to try and catch it that way running under Xen. I will do that tomorrow.

I will report my findings.

best regards,

Andreas Olsowski

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>