This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] kernel BUG at arch/x86/xen/mmu.c:1860!

To: Teck Choon Giam <giamteckchoon@xxxxxxxxx>
Subject: Re: [Xen-devel] kernel BUG at arch/x86/xen/mmu.c:1860!
From: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Date: Tue, 8 Mar 2011 14:29:50 -0500
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, "Fajar A. Nugraha" <list@xxxxxxxxx>
Delivery-date: Tue, 08 Mar 2011 11:33:14 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <AANLkTimin0OZZUmvUr2KcXugc_2GGuEhRHLdug1ufha6@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <AANLkTimPihAQ7Qsh7ViQVEgNP0hbTRhiXsU42N+3ROcc@xxxxxxxxxxxxxx> <20110127203218.GB4194@xxxxxxxxxxxx> <AANLkTinZZC-oGoJ85tnFSLMs9xDEC2PndkrzLB_gseO5@xxxxxxxxxxxxxx> <AANLkTi=p7aCFAC448fgDC46chMSr6Fm7=FsPqDkL23Jy@xxxxxxxxxxxxxx> <20110228162023.GA11720@xxxxxxxxxxxx> <AANLkTikYnh0xbHLtyAR71FAOT18+g6SPxo25CGz5gKwh@xxxxxxxxxxxxxx> <20110303221639.GB12175@xxxxxxxxxxxx> <AANLkTi=r+ErO+PkPWF=3L8+v9+TPbgVz-6qaycTgMo4c@xxxxxxxxxxxxxx> <AANLkTimTuXqoLe9VinpAdhwJPO3Z8HGU2+KOoHOBaUvq@xxxxxxxxxxxxxx> <AANLkTimin0OZZUmvUr2KcXugc_2GGuEhRHLdug1ufha6@xxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.20 (2009-06-14)
> Yes.  All are set in my kernel config and I believed Konrad has my kernel
> config.  I didn't use nomodeset as my servers don't have those graphic
> cards... ...

I am having a hard-time reproducing this. I made six LV's:
[root@tst011 ~]# lvs
  LV                   VG         Attr   LSize  Origin      Snap%  Move Log 
Copy%  Convert
  LogVol00             VolGroup00 -wi-ao 17.56G                                 
  LogVol01             VolGroup00 -wi-ao  5.81G                                 
  data-1.ext3          XenGroup   -wi-ao 10.00G                                 
  data-2.ext3          XenGroup   owi-ao 10.00G                                 
  data-2.ext3-snapshot XenGroup   swi-a-  1.00G data-2.ext3   2.41              
  data-3.ext3          XenGroup   -wi-a- 10.00G                                 
  scratch-1.ext3       XenGroup   -wi-ao 10.00G                                 
  scratch-2.ext3       XenGroup   -wi-ao 10.00G                                 
  scratch-3.ext3       XenGroup   -wi-a- 10.00G                                 
[root@tst011 ~]# 

Where each scratch-X/data-X was prepared with 'mkfs.ext3'

And ran two guests, where each guest configuration looks as so:

extra="console=hvc0 debug"
#vif = [ 'mac=00:0f:4b:00:00:68, bridge=switch' ]
vfb = [ 'vnc=1, vnclisten=,vncunused=1']
disk = [ 'phy:/dev/XenGroup/scratch-1.ext3,xvda,w', 

(the other is using -2 obviously).

And each guest is running 'mount /dev/xvda /mnt-1;(cd /mnt-1;fio 
to produce I/Os on the xvdb/xvda disks.

As those guests are chugging along, I ran your script with:

root      6250  4438  0 10:12 pts/4    00:00:00 /bin/sh ./lvm-test.sh loop 100 
1G 5

(I tried 100 1G 0)

and so far it is running.... how long should I wait until I hit this problem?

This is on CentOS 5.5 and also on Fedora Core 13. Dom0 and DomU are all x86_64.

Dom0 is:

commit 892d2f052e979cf1916647c752b94cf62ec1c6dc
Merge: 35e2e28... 376faec...
Author: Jeremy Fitzhardinge <jeremy.fitzhardinge@xxxxxxxxxx>
Date:   Fri Feb 11 13:31:03 2011 -0800

    Merge commit 'v2.6.32.28' into xen/next-2.6.32

(plus one patch I just posted - but that is to fix the serial console, so
it is not relevant to this problem).

DomU is 2.6.38 kernel, but I can swap over to the same as Dom0..

Attached is the script I am using.

Attachment: iometer-file-access-server
Description: Text document

Attachment: lvm-test.sh
Description: Bourne shell script

Xen-devel mailing list