This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: xen-unstable: ImportError: No module named xen.xm

To: Xen-Devel List <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] Re: xen-unstable: ImportError: No module named xen.xm
From: chris <tknchris@xxxxxxxxx>
Date: Wed, 19 Jan 2011 17:34:24 -0500
Cc: Xen-Users List <xen-users@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Wed, 19 Jan 2011 14:40:12 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:in-reply-to:references:date :message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=77ulc2vOqk70+Uu7UNpXa9cIc260Z568StdiEay8oS4=; b=u/17b0lzK/hyrzuvY4+bAvU01LGVIOg+QzsWpdOJhrGGcHDKqGp/mM5sASsMcOPh4B gG1fXElR0g5yUz8u5qZvmkkvZ0JjVCBNF55s4Oneh6bpYkrgLGR36dXqSuzVQbQjlUmf XtuF4kuZ6aj3Z3GlNIQkY63oyP+VqMSKfIHEo=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=O6PFvkEHSLiEfksPUWj2y7jRM4Q0YeZYpM+Gx3QouAK1CqcK1llUVhXVfluNHZZlc+ qS/ZBIZp0XxSDBA5+AHTZzPZfHO/CrTFycK1masl3R0j5MBvwz9X8cnx+jCeAZv+ghYT DphJG2AdzJ6mO4sL9zuSCs2Ap0iyECGVsDzCY=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <AANLkTimCA_T1QsfCVfABtW8776Mkg3toBtmHYHgea56=@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <AANLkTimCA_T1QsfCVfABtW8776Mkg3toBtmHYHgea56=@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
On Wed, Jan 19, 2011 at 2:29 PM, chris <tknchris@xxxxxxxxx> wrote:
> I have pulled the latest from xen-unstable on a new machine, I run
> make world and make install and after rebooting into xen, when i run
> xm list or anything else i get:
> # xm list
> Traceback (most recent call last):
>  File "/usr/sbin/xm", line 5, in <module>
>    from xen.xm import main
> ImportError: No module named xen.xm
> I also tried going into the tools dir and make install, because i read
> that somewhere on google.
> I don't get any errors when compiling or installing so I don't know
> where to go from here?
> - chris

I just tried this again after pulling everything down again and
recompiling. Is something broken?

Xen-users mailing list