This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] [PATCH V3 0/6] firmware changes as part of QEMU/Xen merg

To: Keir Fraser <keir@xxxxxxx>
Subject: Re: [Xen-devel] [PATCH V3 0/6] firmware changes as part of QEMU/Xen merge.
From: Pasi Kärkkäinen <pasik@xxxxxx>
Date: Fri, 29 Oct 2010 16:27:42 +0300
Cc: anthony.perard@xxxxxxxxxx, Xen Devel <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Fri, 29 Oct 2010 06:30:21 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <C8F08835.8A8E%keir@xxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <C8F087D8.8A86%keir@xxxxxxx> <C8F08835.8A8E%keir@xxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.18 (2008-05-17)
On Fri, Oct 29, 2010 at 02:18:29PM +0100, Keir Fraser wrote:
> On 29/10/2010 14:16, "Keir Fraser" <keir@xxxxxxx> wrote:
> >> Should it be called something else than HVM_PARAM_ACPI_NEW_IOPORT ?
> >> After a couple of years "NEW" might not make much sense anymore..
> >> 
> >> IOPORT_V2 ? Or something..
> > 
> > I've asked for a nice big explanatory comment to be added beside the
> > parameter's definition. Also we should treat this field as a version number,
> > so baking a fixed version into its name is not a good idea. With the
> > explanatory comment, I think its existing name is good enough. To do much
> > better the name would have to become cumbersomely long.
> That said, HVM_PARAM_ACPI_IOPORTS_LOCATION might be better... I'm not
> personally that fussed either way however.

Yeah, that sounds good..

-- Pasi

Xen-devel mailing list