This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] problem using compiled kernel -- Sisu

 On 07/26/2010 10:48 PM, Sisu Xi wrote:
Hi, Jeremy:

I have retried Linux on Ubuntu 10.04, with Xen 4.0, using your git.

the vmlinux and .config file is attached.

This time it shows the following error on the serial console:

Please try to capture a *full* log output. If you're using "screen" you should be able to save everything to a logfile.

[    0.000000] Xen version: 4.0.1-rc5-pre (preserve-AD) (dom0)
[    0.000000] NR_CPUS:8 nr_cpumask_bits:8 nr_cpu_ids:2 nr_node_ids:1
[    0.000000] PERCPU: Embedded 15 pages/cpu @cb6dc000 s39320 r0 d22120 u65536
[    0.000000] pcpu-alloc: s39320 r0 d22120 u65536 alloc=16*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1
[    0.000000] Xen: using vcpu_info placement
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.
Total pages: 481035
[    0.000000] Kernel command line: earlyprintk=xen
[    0.000000] PID hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[    0.000000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Enabling fast FPU save and restore... done.
[    0.000000] Enabling unmasked SIMD FPU exception support... done.
[    0.000000] Initializing CPU#0
[    0.000000] allocated 9698480 bytes of page_cgroup
[    0.000000] please try 'cgroup_disable=memory' option if you don't
want memory cgroups
[    0.000000] DMA: Placing 64MB software IO TLB between cc100000 - d0100000
[    0.000000] DMA: software IO TLB at phys 0xc100000 - 0x10100000
[    0.000000] xen_swiotlb_fixup: buf=cc100000 size=67108864
[    0.000000] xen_swiotlb_fixup: buf=d0160000 size=32768
[    0.000000] Initializing HighMem for node 0 (0002d1fe:0007663c)
[    0.000000] Memory: 1676984k/1939696k available (4734k kernel code,
261416k reserved, 2167k data, 680k init, 1200376k highmem)
[    0.000000] virtual kernel memory layout:
[    0.000000]     fixmap  : 0xf571e000 - 0xf57ff000   ( 900 kB)
[    0.000000]     pkmap   : 0xf5200000 - 0xf5400000   (2048 kB)
[    0.000000]     vmalloc : 0xed9fe000 - 0xf51fe000   ( 120 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xed1fe000   ( 721 MB)
[    0.000000]       .init : 0xc07be000 - 0xc0868000   ( 680 kB)
[    0.000000]       .data : 0xc059fa33 - 0xc07bd8e8   (2167 kB)
[    0.000000]       .text : 0xc0100000 - 0xc059fa33   (4734 kB)
[    0.000000] SLUB: Genslabs=13, HWalign=128, Order=0-3,
MinObjects=0, CPUs=2, Nodes=1
[    0.000000] Hierarchical RCU implementation.
[    0.000000] NR_IRQS:2304 nr_irqs:768
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    0.000000] xen: sci override: source_irq=9 global_irq=9 trigger=c polarity=1
[    0.000000] xen_allocate_pirq: returning irq 9 for gsi 9
[    0.000000] xen: acpi sci 9
[    0.000000] Console: colour VGA+ 80x25
[    0.000000] console [tty0] enabled, bootconsole disabled
(XEN) PCI add device 00:00.0
(XEN) PCI add device 00:01.0
(XEN) PCI add device 00:1c.0
(XEN) PCI add device 00:1c.1
(XEN) PCI add device 00:1d.0
(XEN) PCI add device 00:1d.1
(XEN) PCI add device 00:1d.2
(XEN) PCI add device 00:1d.3
(XEN) PCI add device 00:1d.7
(XEN) PCI add device 00:1e.0
(XEN) PCI add device 00:1e.2
(XEN) PCI add device 00:1f.0
(XEN) PCI add device 00:1f.1
(XEN) PCI add device 00:1f.2
(XEN) PCI add device 00:1f.3
(XEN) PCI add device 01:00.0
(XEN) PCI add device 01:00.1
(XEN) PCI add device 02:00.0
(XEN) PCI add device 04:00.0

after that, the serial output stops, and the target machines stops at the:
usbhid: v2.6: USB HID core driver
Gave up waiting for root device. Common problems:
- Boot args (cat /proc/cmdline)
   -check rootdelay= (did the system wait long enough?)
   -check root= (did the system wait for the right device?)
- Missing modules (cat /proc/modules; ls /dev)
ALERT! does not exist. Dropping to a shell!

BusyBox built-in shell (ash)


Could you help me with this?

Not really. This is quite different from the original report of an early oops, which was clearly a kernel problem. This seems to be something wrong with your kernel config (either compile-time or runtime). Make sure you have device drivers enabled for all your devices, that your initrd contains those drivers, and your distros startup scripts are doing the right thing. I'm not familiar with any busybox-using distros, so I can't help in detail. Make sure your console on the kernel command line is "console=hvc0", and "ignore_loglevel" is also useful to make sure all the console output is printed.


Thanks very much!



On Mon, Jul 26, 2010 at 10:08 PM, Sisu Xi<xisisu@xxxxxxxxx>  wrote:
I download them directly from kernel.org and configured it following
the tutorial.

I have also tried both the kernel and the kernel
from git.kernel.org/pub/scm/linux/kernel/git/jeremy/xen.git,
they all give the same error message

thanks very much!



On Mon, Jul 26, 2010 at 10:05 PM, Jeremy Fitzhardinge<jeremy@xxxxxxxx>  wrote:
  On 07/26/2010 07:15 PM, Sisu Xi wrote:
Sorry I forgot to attach the file.

Here they are.

Which branch/source are these from?  The xen/stable-2.6.32.x branch is the
most supported for dom0 use at the moment.



On Mon, Jul 26, 2010 at 9:13 PM, Sisu Xi<xisisu@xxxxxxxxx>    wrote:
Hi, Jeremy:

Thanks for the reply!

I am using screen on Mac to show the serial debug info,

my .config file and vmlinux file are in the attachment.

Thanks very much!



On Mon, Jul 26, 2010 at 9:02 PM, Jeremy Fitzhardinge<jeremy@xxxxxxxx>
  On 07/26/2010 02:57 PM, Sisu Xi wrote:
Hi, all:

I have compiled Xen 4.0 from the source. it goes as the tutorials says.

Then I download the kernel to compile it, (tried,,, following the instructions to configure the kernel, and
tried on Fedora 13 and Ubuntu 10.04. The kernel compiles with no
error, and I configured the grub to show the debug info through a
serial port.

But I got the same error message, which is:

(XEN)  Xen  kernel: 32-bit, PAE, lsb
(XEN)  Dom0 kernel: 32-bit, PAE, lsb, paddr 0x100000 ->      0xa45000
(XEN)  Dom0 alloc.:   0000000020000000->0000000030000000 (419388 pages
to be allocated)
(XEN)  Loaded kernel: c0100000->c0a45000
(XEN)  Init. ramdisk: c0a45000->ca662000
(XEN)  Phys-Mach map: ca662000->ca83b8f0
(XEN)  Start info:    ca83c000->ca83c47c
(XEN)  Page tables:   ca83d000->ca898000
(XEN)  Boot stack:    ca898000->ca899000
(XEN)  TOTAL:         c0000000->cac00000
(XEN)  ENTRY ADDRESS: c07ca000
(XEN) Dom0 has maximum 2 VCPUs
(XEN) Scrubbing Free RAM: .done.
(XEN) Xen trace buffers: disabled
(XEN) Std. Loglevel: Errors and warnings
(XEN) Guest Loglevel: Nothing (Rate-limited: Errors and warnings)
(XEN) *** Serial input ->      DOM0 (type 'CTRL-a' three times to switch
input to Xen)
(XEN) Freed 156kB init memory.
mapping kernel into physical memory
about to get started...
[    0.000000] Reserving virtual address space above 0xf5800000
(XEN) d0:v0: unhandled page fault (ec=0000)
(XEN) Pagetable walk from 15555c08:
(XEN)  L3[0x000] = 000000002a83e001 0000a83e
(XEN)  L2[0x0aa] = 0000000000000000 ffffffff
(XEN) domain_crash_sync called from entry.S (ff1cbe3e)
(XEN) Domain 0 (vcpu#0) crashed on cpu#0:
(XEN) ----[ Xen-4.0.1-rc5-pre  x86_32p  debug=n  Not tainted ]----
(XEN) CPU:    0
(XEN) EIP:    e019:[<c03dcc4d>]
(XEN) EFLAGS: 00000206   EM: 1   CONTEXT: pv guest
(XEN) eax: 00000000   ebx: 00000000   ecx: 00000008   edx: c0710d3d
(XEN) esi: 15555000   edi: c07c6a24   ebp: c0777dac   esp: c0777d50
(XEN) cr0: 8005003b   cr4: 000026f0   cr3: 20779000   cr2: 15555c08
(XEN) ds: e021   es: e021   fs: 00d8   gs: 00e0   ss: e021   cs: e019
(XEN) Guest stack trace from esp=c0777d50:
(XEN)    00000000 c03dcc4d 0001e019 00010006 00000000 c0777d7c c0777d84
(XEN)    c0710d3d 00000000 00000008 c0777dc0 c01315ce 00000000 00000000
(XEN)    00000001 00000000 00000000 00000000 00000000 00000000 c07c6a24
(XEN)    c03dce01 c089af63 00000040 c089af63 00000040 c07ac7e0 c03dcda0
(XEN)    c0777dec c0151b84 00000040 00000003 00000043 00000043 00000006
(XEN)    c0151bee 00000043 0000023d c0777e24 c0152065 0001ffff 367ac7e0
(XEN)    00000006 00000000 00000000 c07ac7e0 c089aec0 c0777e50 c0152a30
(XEN)    00000000 c08baf83 00000034 006ce332 00000000 c0804fac 00000000
(XEN)    c0777e60 c012d796 00000000 c0804fac c0777e70 c07de331 c0850d28
(XEN)    c0777e8c c07ca9f4 b1b5e716 c088e9c0 c0804fa0 0000005f fffffffe
(XEN)    c016c20f c0777ea4 c0777ecc c07d0a11 c06ce332 c06ccf4b 00000000
(XEN)    c0804fac c0804faf c0804faf 0000000b 00000000 c080964c c088e8cc
(XEN)    c07ca298 00000000 c07ca9a8 c0777ee4 c07ca631 c0777f84 c07cf64f
(XEN)    c0777f41 c0777f74 c0106a9e ffffffff c0152585 c0777f32 c06dc201
(XEN)    00000000 c0777f32 00000000 00000000 c08baf83 00000035 0000000f
(XEN)    205b0000 30202020 3030302e c0777fa8 00000020 00000000 c08bcb3c
(XEN)    00000000 0a662000 c0777f6c c0106a9e 00000000 b1b5e716 00000000
(XEN)    0a662000 b1b5e716 00000000 00000000 0a662000 c0777fb0 c07ca70f
(XEN)    c05aa040 00000000 08d30cf4 00000001 b1b5e716 577d377b c0807f60
(XEN)    c0777fd0 c07ca0ef 0a662000 00000000 c06ce77d 00a45000 ca83c000
(XEN) Domain 0 crashed: rebooting machine in 5 seconds.

Does anyone know how to solve this prob?
Could you post the full boot log from Xen, your vmlinux file and your


Xen-devel mailing list