This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] problem using compiled kernel -- Sisu

To: Sisu Xi <xisisu@xxxxxxxxx>
Subject: Re: [Xen-devel] problem using compiled kernel -- Sisu
From: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Date: Mon, 26 Jul 2010 19:02:26 -0700
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 26 Jul 2010 19:03:03 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <AANLkTikYtmsbGsbONAaBXNwUY-rGe-gw+iN9BSYjtZnT@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <AANLkTikYtmsbGsbONAaBXNwUY-rGe-gw+iN9BSYjtZnT@xxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100720 Fedora/3.1.1-1.fc13 Lightning/1.0b2pre Thunderbird/3.1.1
 On 07/26/2010 02:57 PM, Sisu Xi wrote:
Hi, all:

I have compiled Xen 4.0 from the source. it goes as the tutorials says.

Then I download the kernel to compile it, (tried,,, following the instructions to configure the kernel, and
tried on Fedora 13 and Ubuntu 10.04. The kernel compiles with no
error, and I configured the grub to show the debug info through a
serial port.

But I got the same error message, which is:

(XEN)  Xen  kernel: 32-bit, PAE, lsb
(XEN)  Dom0 kernel: 32-bit, PAE, lsb, paddr 0x100000 ->  0xa45000
(XEN)  Dom0 alloc.:   0000000020000000->0000000030000000 (419388 pages
to be allocated)
(XEN)  Loaded kernel: c0100000->c0a45000
(XEN)  Init. ramdisk: c0a45000->ca662000
(XEN)  Phys-Mach map: ca662000->ca83b8f0
(XEN)  Start info:    ca83c000->ca83c47c
(XEN)  Page tables:   ca83d000->ca898000
(XEN)  Boot stack:    ca898000->ca899000
(XEN)  TOTAL:         c0000000->cac00000
(XEN)  ENTRY ADDRESS: c07ca000
(XEN) Dom0 has maximum 2 VCPUs
(XEN) Scrubbing Free RAM: .done.
(XEN) Xen trace buffers: disabled
(XEN) Std. Loglevel: Errors and warnings
(XEN) Guest Loglevel: Nothing (Rate-limited: Errors and warnings)
(XEN) *** Serial input ->  DOM0 (type 'CTRL-a' three times to switch
input to Xen)
(XEN) Freed 156kB init memory.
mapping kernel into physical memory
about to get started...
[    0.000000] Reserving virtual address space above 0xf5800000
(XEN) d0:v0: unhandled page fault (ec=0000)
(XEN) Pagetable walk from 15555c08:
(XEN)  L3[0x000] = 000000002a83e001 0000a83e
(XEN)  L2[0x0aa] = 0000000000000000 ffffffff
(XEN) domain_crash_sync called from entry.S (ff1cbe3e)
(XEN) Domain 0 (vcpu#0) crashed on cpu#0:
(XEN) ----[ Xen-4.0.1-rc5-pre  x86_32p  debug=n  Not tainted ]----
(XEN) CPU:    0
(XEN) EIP:    e019:[<c03dcc4d>]
(XEN) EFLAGS: 00000206   EM: 1   CONTEXT: pv guest
(XEN) eax: 00000000   ebx: 00000000   ecx: 00000008   edx: c0710d3d
(XEN) esi: 15555000   edi: c07c6a24   ebp: c0777dac   esp: c0777d50
(XEN) cr0: 8005003b   cr4: 000026f0   cr3: 20779000   cr2: 15555c08
(XEN) ds: e021   es: e021   fs: 00d8   gs: 00e0   ss: e021   cs: e019
(XEN) Guest stack trace from esp=c0777d50:
(XEN)    00000000 c03dcc4d 0001e019 00010006 00000000 c0777d7c c0777d84 00000008
(XEN)    c0710d3d 00000000 00000008 c0777dc0 c01315ce 00000000 00000000 08dabc4e
(XEN)    00000001 00000000 00000000 00000000 00000000 00000000 c07c6a24 c0777dd0
(XEN)    c03dce01 c089af63 00000040 c089af63 00000040 c07ac7e0 c03dcda0 c07c6a24
(XEN)    c0777dec c0151b84 00000040 00000003 00000043 00000043 00000006 c0777dfc
(XEN)    c0151bee 00000043 0000023d c0777e24 c0152065 0001ffff 367ac7e0 fffffdc3
(XEN)    00000006 00000000 00000000 c07ac7e0 c089aec0 c0777e50 c0152a30 00000000
(XEN)    00000000 c08baf83 00000034 006ce332 00000000 c0804fac 00000000 c0804fac
(XEN)    c0777e60 c012d796 00000000 c0804fac c0777e70 c07de331 c0850d28 c0804fa0
(XEN)    c0777e8c c07ca9f4 b1b5e716 c088e9c0 c0804fa0 0000005f fffffffe c0777ecc
(XEN)    c016c20f c0777ea4 c0777ecc c07d0a11 c06ce332 c06ccf4b 00000000 00000000
(XEN)    c0804fac c0804faf c0804faf 0000000b 00000000 c080964c c088e8cc c0777edc
(XEN)    c07ca298 00000000 c07ca9a8 c0777ee4 c07ca631 c0777f84 c07cf64f 00000095
(XEN)    c0777f41 c0777f74 c0106a9e ffffffff c0152585 c0777f32 c06dc201 00000000
(XEN)    00000000 c0777f32 00000000 00000000 c08baf83 00000035 0000000f 00000000
(XEN)    205b0000 30202020 3030302e c0777fa8 00000020 00000000 c08bcb3c 00000000
(XEN)    00000000 0a662000 c0777f6c c0106a9e 00000000 b1b5e716 00000000 00000000
(XEN)    0a662000 b1b5e716 00000000 00000000 0a662000 c0777fb0 c07ca70f c06ccfca
(XEN)    c05aa040 00000000 08d30cf4 00000001 b1b5e716 577d377b c0807f60 00a45000
(XEN)    c0777fd0 c07ca0ef 0a662000 00000000 c06ce77d 00a45000 ca83c000 c078c960
(XEN) Domain 0 crashed: rebooting machine in 5 seconds.

Does anyone know how to solve this prob?

Could you post the full boot log from Xen, your vmlinux file and your .config?


Xen-devel mailing list