This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] crash e100 amd64 >=4GB RAM

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] crash e100 amd64 >=4GB RAM
From: "Daniel Schmitt" <daniel.schmitt@xxxxxxx>
Date: Wed, 26 May 2010 22:28:05 +0200
Delivery-date: Wed, 26 May 2010 13:29:58 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
Importance: Normal
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Reply-to: daniel.schmitt@xxxxxxx
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: SquirrelMail/1.4.20
Hello list,

I'm using gentoo Linux with xen 3.4.1 and linux kernel 2.6.30 fine till
now where I need more RAM. I used 2GB and now I want to use 4GB.
But upping eth0 (4-port e100 Quad Port Device by Compaq) crashed the kernel.
I tried xen 4.0.0 with linux kernel 2.6.32, same error.
Using swiotlb=force or swiotlb=128,force or iommu=off did not succeed even.
The board has a tg3 gigabit NIC, too. Upping this device does not crash
the kernel.
It must have something to do with e100 driver.

Can anyone help?

Here is some crash information:
kernel BUG at lib/swiotlb-xen.c:454!
[<ffffffff80481120>] e100_rx_alloc_skb+0x190/0x230
RIP [<ffffffff803c56a6>] swiotlb_sync_single_for_device+0x96/0xe0
Segmentation fault

Thanks for your help,

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>