This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] crash e100 amd64 >=4GB RAM

To: Daniel Schmitt <daniel.schmitt@xxxxxxx>
Subject: Re: [Xen-devel] crash e100 amd64 >=4GB RAM
From: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Date: Thu, 27 May 2010 11:29:00 -0400
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 27 May 2010 08:31:08 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <178a7c8c6f1dbc6bc3dc1dd17f63a8fc.squirrel@xxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <178a7c8c6f1dbc6bc3dc1dd17f63a8fc.squirrel@xxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.19 (2009-01-05)
On Wed, May 26, 2010 at 10:28:05PM +0200, Daniel Schmitt wrote:
> Hello list,
> I'm using gentoo Linux with xen 3.4.1 and linux kernel 2.6.30 fine till
> now where I need more RAM. I used 2GB and now I want to use 4GB.
> But upping eth0 (4-port e100 Quad Port Device by Compaq) crashed the kernel.
> I tried xen 4.0.0 with linux kernel 2.6.32, same error.
> Using swiotlb=force or swiotlb=128,force or iommu=off did not succeed even.
> The board has a tg3 gigabit NIC, too. Upping this device does not crash
> the kernel.
> It must have something to do with e100 driver.
> Can anyone help?

Yes. Please follow these steps:

> Here is some crash information:
> ------------------------
> kernel BUG at lib/swiotlb-xen.c:454!
> [<ffffffff80481120>] e100_rx_alloc_skb+0x190/0x230
> ...
> RIP [<ffffffff803c56a6>] swiotlb_sync_single_for_device+0x96/0xe0
> Segmentation fault
> ------------------------
> Thanks for your help,
> Daniel
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-devel

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>