This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] xen-unstable + pvops-kernel doesn't boot on my machine,

To: Min Lee <min.lee@xxxxxxxxxx>
Subject: Re: [Xen-devel] xen-unstable + pvops-kernel doesn't boot on my machine, ibm x3550M2
From: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Date: Wed, 26 May 2010 15:45:45 -0400
Cc: Xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 26 May 2010 12:48:31 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4BFD5867.7090104@xxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4BFD5867.7090104@xxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.19 (2009-01-05)
On Wed, May 26, 2010 at 01:20:39PM -0400, Min Lee wrote:
> Hello.
> I've tried Xen-unstable + Jeremy's pvops kernel on ibm x3550M2 server  
> machine, but it fails to mount root fs.

What is the distro you have? If it is RHEL5 look also:

> I'm using ibm x3550M2 server with broadcom NetXtreme II network card, and 
> ibm RAID. (64bit)
> Even running pvops-kernel without xen fails, too, and I could see this  
> booting message.
> pci 0000:01:00.0: BAR 6: no parent found for of device [0xffff0000-ffffffff]
> Module for the raid (megaraid_sas.ko) is in initrd file.
> I've also tried xen-unstable + 2.6.18-xen and it boots, but it doesn't  
> detect my network card.
> it seems like it fails to allocate apic I/O resources.
> Anybody who's running xen-unstable on similar configuration ??

Please follow http://wiki.xensource.com/xenwiki/XenParavirtOps the
'Troubleshooting..' section and also the 
"Are there more debugging options I could enable to troubleshoot booting

Please attach the full debug serial console. I belive that machine has
an IPMI BMC, so you should be able to use SOL. Look for details on:

> Thank you for any comments or help.
> Min
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-devel

Xen-devel mailing list