This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] xen-unstable + pvops-kernel doesn't boot on my machine, ibm

To: Xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] xen-unstable + pvops-kernel doesn't boot on my machine, ibm x3550M2
From: Min Lee <min.lee@xxxxxxxxxx>
Date: Wed, 26 May 2010 13:20:39 -0400
Delivery-date: Wed, 26 May 2010 10:22:44 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100317 Thunderbird/3.0.4
I've tried Xen-unstable + Jeremy's pvops kernel on ibm x3550M2 server machine, but it fails to mount root fs. I'm using ibm x3550M2 server with broadcom NetXtreme II network card, and ibm RAID. (64bit) Even running pvops-kernel without xen fails, too, and I could see this booting message.

pci 0000:01:00.0: BAR 6: no parent found for of device [0xffff0000-ffffffff]

Module for the raid (megaraid_sas.ko) is in initrd file.
I've also tried xen-unstable + 2.6.18-xen and it boots, but it doesn't detect my network card.
it seems like it fails to allocate apic I/O resources.
Anybody who's running xen-unstable on similar configuration ??
Thank you for any comments or help.

Xen-devel mailing list