This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] need known working 64-bit upstream kernel config file fo

Just thought I'd follow up on this.  I'm still not positive
but it appears that the problem I'm seeing is a kernel-build
process problem.  It appears that on some kernels, if I
build with:

make -j4; make -j4 modules modules_install; make install

then the resultant kernel (often) fails and if I build with:

make; make modules; make modules_install; make install

then the resultant kernel boots.

I reproduced this, but don't really have time to track down what
the failure is.  I usually build in a VNC console window and don't
redirect output of make so it's possible I've gotten error messages
that I've missed/ignored.  Maybe it occurs only with Xen modules
because otherwise I'm sure some Linux developer would have
seen it.  Since the symptom is that the kernel fails looking
for a root disk using exactly the same parameters and same
disk that work fine for a different kernel, it may have
something to do with xenblk.

Weird but apparently true.  And now that I have 2.6.34 working
in both 32-bit and 64-bit PV, I really have to quit looking into
this now.


> -----Original Message-----
> From: Dan Magenheimer
> Sent: Friday, May 14, 2010 12:11 PM
> To: Pasi Kärkkäinen
> Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
> Subject: RE: [Xen-devel] need known working 64-bit upstream kernel
> config file for PV guest
> > > To add one more very interesting piece of data,
> > > booting a 2.6.32 32-bit kernel.org kernel in a PV
> > > guest works, while booting a 32-bit
> > > kernel.org kernel doesn't... same config file!
> > > And the failure looks very similar to the one
> > > I've been seeing on several x86_64 kernel.org
> > > kernels.
> > >
> > > I'll confirm that I can reproduce this, and then
> > > post as a separate thread.
> > >
> >
> > I tried both 32bit and 64bit Linux upstream
> > kernel.org kernels, and they worked ok for me.
> >
> > That was actually save/restore testing, which also worked OK,
> > for both uni-vcpu and multi-vcpu guests.
> >
> > Dom0 was EL5.
> Well... I couldn't reproduce it and, as a result, I discovered
> another difference: 2.6.32 x86 fails also (as well as
> x86), when I am booting it in EL5u5.  But it succeeds in EL5u4!
> Perhaps there is a different nash version between the two?
> Sorry if this appears terribly disorganized and disjointed.
> I am trying to use two machines with not quite identical
> environments so that I can get two other things done during
> long kernel compiles.  As a result, I've missed some seemingly
> irrelevant details that are turning out to be relevant.

Xen-devel mailing list