This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] need known working 64-bit upstream kernel config file fo

To: "Pasi Kärkkäinen" <pasik@xxxxxx>
Subject: RE: [Xen-devel] need known working 64-bit upstream kernel config file for PV guest
From: Dan Magenheimer <dan.magenheimer@xxxxxxxxxx>
Date: Fri, 14 May 2010 11:10:37 -0700 (PDT)
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 14 May 2010 11:13:25 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20100514174239.GX17817@xxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20100513203053.GJ17817@xxxxxxxxxxx> <fd6d1882-5846-47bf-a2e1-6e77d458b0f4@default 20100514174239.GX17817@xxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
> > To add one more very interesting piece of data,
> > booting a 2.6.32 32-bit kernel.org kernel in a PV
> > guest works, while booting a 32-bit
> > kernel.org kernel doesn't... same config file!
> > And the failure looks very similar to the one
> > I've been seeing on several x86_64 kernel.org
> > kernels.
> >
> > I'll confirm that I can reproduce this, and then
> > post as a separate thread.
> >
> I tried both 32bit and 64bit Linux upstream
> kernel.org kernels, and they worked ok for me.
> That was actually save/restore testing, which also worked OK,
> for both uni-vcpu and multi-vcpu guests.
> Dom0 was EL5.

Well... I couldn't reproduce it and, as a result, I discovered
another difference: 2.6.32 x86 fails also (as well as
x86), when I am booting it in EL5u5.  But it succeeds in EL5u4!
Perhaps there is a different nash version between the two?

Sorry if this appears terribly disorganized and disjointed.
I am trying to use two machines with not quite identical
environments so that I can get two other things done during
long kernel compiles.  As a result, I've missed some seemingly
irrelevant details that are turning out to be relevant.

Xen-devel mailing list