This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] need known working 64-bit upstream kernel config file fo

To: Dan Magenheimer <dan.magenheimer@xxxxxxxxxx>
Subject: Re: [Xen-devel] need known working 64-bit upstream kernel config file for PV guest
From: Pasi Kärkkäinen <pasik@xxxxxx>
Date: Fri, 14 May 2010 20:42:39 +0300
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 14 May 2010 10:48:13 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <fd6d1882-5846-47bf-a2e1-6e77d458b0f4@default>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20100513203053.GJ17817@xxxxxxxxxxx> <fd6d1882-5846-47bf-a2e1-6e77d458b0f4@default>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.18 (2008-05-17)
On Fri, May 14, 2010 at 09:58:47AM -0700, Dan Magenheimer wrote:
> > But I hadn't noticed the problem in the earlier part of
> > the boot before you pointed it out.
> > I'm beginning to suspect that there is a bug in 64-bit
> > upstream kernels that is exposed in nash (the lightweight
> > shell that gets bundled in a RedHat initrd).  If so,
> > it will be very difficult to track down, though clearly
> > it is fixed in one of the many Fedora kernel patches.
> > So I am going to give up on 64-bit upstream kernels
> > for now so I can get some other things done and
> > come back to this later.
> To add one more very interesting piece of data,
> booting a 2.6.32 32-bit kernel.org kernel in a PV
> guest works, while booting a 32-bit
> kernel.org kernel doesn't... same config file!
> And the failure looks very similar to the one
> I've been seeing on several x86_64 kernel.org
> kernels.
> I'll confirm that I can reproduce this, and then
> post as a separate thread.

I tried both 32bit and 64bit Linux upstream 
kernel.org kernels, and they worked ok for me. 

That was actually save/restore testing, which also worked OK,
for both uni-vcpu and multi-vcpu guests.

Dom0 was EL5.

-- Pasi

Xen-devel mailing list