This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] AMD Phenom II 940: Upgrade to fixes it and upgrade

To: Gerry Reno <greno@xxxxxxxxxxx>, dan.magenheimer@xxxxxxxxxx
Subject: [Xen-devel] AMD Phenom II 940: Upgrade to fixes it and upgrades CPU from 3.1Ghz to 1.2Thz!
From: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Date: Mon, 10 May 2010 12:17:03 -0400
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 10 May 2010 09:18:26 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4BE82E3D.5090405@xxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <482967.72793.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx> <4BE44375.1030300@xxxxxxxxxxx> <4BE48BE4.8000607@xxxxxxxxxxx> <20100510141038.GA29517@xxxxxxxxxxxxxxxxxxx> <4BE82E3D.5090405@xxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.19 (2009-01-05)
On Mon, May 10, 2010 at 12:03:09PM -0400, Gerry Reno wrote:
> On 05/10/2010 10:10 AM, Konrad Rzeszutek Wilk wrote:
>>> Ok, I tried to adjust bridge parameters and found that I can finally get
>>> pv_ops dom0 to boot in normal timeframe if I comment out all bridge
>>> related statements in /etc/xen/xend-config.sxp.  Before with I
>>> had (network-script network-bridge) and also tried (network-script
>>> 'network-bridge bridge=br0') but these do not work with
>> I had this problem when I forgot to have 'CONFIG_BRIDGE' enabled in my
>> .config, and also CONFIG_TAP (but I think that was only used during
>> guest startup) but I don't think that is your problem. It could be related to
>> this:
>> "init: eucalyptus-network (eth0) main process (1156) killed by TERM signal"
>> which might have mangled the eth0? Why is it being killed?
> I'm going to investigate this but I suspect it dies because eth0 isn't  
> there.  The euca network works fine after I restart networking.

Uh, why isn't eth0 there? The kernel log looks to have 'eth0' setup. Did
it get renamed?
>>> However, there are still errors in the pv_ops dom0 console
>>> output so I'm attaching the output so someone could see if they are
>>> serious or if there are workarounds to improve things.  I'm seeing
>>> things like 'unable to locate IOAPIC for xxx', call trace from
>> Don't worry about that. These are used to setup the GSI and there is a
>> second code path that does that.
> Ok.  But then why bother writing these scary messages that just confuse  
> things?

Well, you know.. job security and such :-)

But in all seriousness - I was thinking about doing something about
those pesky messages, but haven't yet come up with a good way of doing

>>> enlighten.c, 'd0 domain attempted wrmsr', 'Detected 1226681.732 MHz
>>> processor.'(a 1.2 TeraHz processor??? - the processor is actually a 3.1

Maybe you should look in a lead case. You know at that speeds your
CPU might be producing X-rays that could be harmful to you.

>>> GHz processor), 'No compatible ACPI _PSS objects found.'.
>> Interesting. My AMD prototype board shows the same data (or sometimes
>> even higher number)- completly bogus.
> I'm wondering if this bothers delay loop timings, etc. ???

Dan, thoughts?

>>> Plus, why do I see slightly different outputs on the consoles?  Some
>>> errors only show on one of the consoles but not the other.
>> That is b/c the Xen console (all prefixed with XEN) shouldn't by default
>> be in the Linux domain, unless requested.
>> .. snip..
>>> (XEN) Command line: dummy=dummy dom0_mem=1024M  vga=text-80x50  loglvl=all 
>>> guest_loglvl=all sync_console console_to_rin1
>>                                              ^'g'
>> or unless you use console_to_ring at which point all of the output
>> should be synced together. Except that you have '1' at the end instead
>> of 'g'.
> The '1' is an artifact due to the command line actually being truncated.  
> It's actually the last character on the line.

Ah, OK.
>> .. snip..
>>> GR: now login prompt shows up immediately:
>> Hurrayy!
> Yeah, no kidding!  :-)
> Thanks for the help and looking at this.

Of course.

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>