This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] AMD Phenom II 940: mm/vmalloc.c:110 vmap_page_range_nofl

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] AMD Phenom II 940: mm/vmalloc.c:110 vmap_page_range_noflush
From: Gerry Reno <greno@xxxxxxxxxxx>
Date: Fri, 07 May 2010 17:53:40 -0400
Delivery-date: Fri, 07 May 2010 14:55:06 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4BE44375.1030300@xxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <482967.72793.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx> <4BE44375.1030300@xxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20100317 Thunderbird/3.0.4
On 05/07/2010 12:44 PM, Gerry Reno wrote:
On 05/07/2010 02:21 AM, Boris Derzhavets wrote:

>> /etc/xen/scripts/network-bridge: line 240: "sigerr" command not found.

apt-get install bridge-utils ( has been done ?)
If yes, you could try remove br0 declaration from /etc/network/interfaces
and edit properly /etc/xen/xend-config.sxp . Xen should bring up bridge
with no pain after reboot. Just service xend restart might not help.
I got this error this error as reaction on any mistake in Xen network config
on Lucid.

P.S. you could keep br0 declaration and commented out network bridging setup
in /etc/xen/xend-config.sxp. It works as well.

--- On Fri, 5/7/10, Pasi Kärkkäinen <pasik@xxxxxx> wrote:

From: Pasi Kärkkäinen <pasik@xxxxxx>
Subject: Re: [Xen-devel] AMD Phenom II 940: mm/vmalloc.c:110 vmap_page_range_noflush
To: "Gerry Reno" <greno@xxxxxxxxxxx>
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, "Konrad Rzeszutek Wilk" <konrad.wilk@xxxxxxxxxx>
Date: Friday, May 7, 2010, 2:05 AM

On Thu, May 06, 2010 at 10:22:03PM -0400, Gerry Reno wrote:
> On 05/06/2010 08:21 PM, Gerry Reno wrote:
>> Ok, I tested with the new  (.config same)
>> Case 1:  Xen 4.0.0-rc8 / pv_ops dom0 kernel
>> Still pv_ops dom0 is not working properly.
>> There are still call trace and other errors.  The kernel does boot up 
>> but it takes again a long time to get the login prompt (about 3 mins). 
>> This is far longer than when I used pv_ops dom0.  Networking
>> does not start properly (only see 'lo' and 'virbr0'), so I have to
>> restart it manually and then I see my bridge 'br0' and 'eth0'.
>> Can't find device "br0"
>> /etc/xen/scripts/network-bridge: line 240: "sigerr" command not found.
>> And it is trying unsuccessfully to start some laptop feature like 
>> S99powernap (unknown job) and also S28-libvirt-bin fails (maybe 
>> network related?).
>> Case 2:  pv_ops domU kernel  (no xen dom0):
>> Now the straight linux kernel (no xen dom0) boots right up and goes to 
>> login prompt in normal timeframe.  Networking starts correctly.   
>> Things look pretty normal.
>> Observation:
>> I'm getting slightly different output on console and serial console.   
>> Some errors show on one but not the other.  Shouldn't these be
>> identical?
>> I'm attaching both serial console outputs.
>> menu.lst is same as before (just .12 instead of .10)
>> -Gerry
> And I'm attaching the syslog from Case 1 (pv_ops dom0).

You should be posting two things:

1) xm dmesg
2) dmesg

Aka the full boot log, from both Xen hypervisor and dom0 Linux kernel.

-- Pasi

Pasi, I am attaching 'xm dmesg' and 'dmesg'.

Boris, bridge-utils is installed and latest.  I will try some of these other things you suggested.


Ok, I tried to adjust bridge parameters and found that I can finally get pv_ops dom0 to boot in normal timeframe if I comment out all bridge related statements in /etc/xen/xend-config.sxp.  Before with I had (network-script network-bridge) and also tried (network-script 'network-bridge bridge=br0') but these do not work with

However, there are still errors in the pv_ops dom0 console output so I'm attaching the output so someone could see if they are serious or if there are workarounds to improve things.  I'm seeing things like 'unable to locate IOAPIC for xxx', call trace from enlighten.c, 'd0 domain attempted wrmsr', 'Detected 1226681.732 MHz processor.'(a 1.2 TeraHz processor??? - the processor is actually a 3.1 GHz processor), 'No compatible ACPI _PSS objects found.'.

Plus, why do I see slightly different outputs on the consoles?  Some errors only show on one of the consoles but not the other.


Attachment: AMD_pvops_dom0_console_2.6.32.12_20100507.txt
Description: Text document

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>