This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] Vt-d not working with 3.4.1

To: <pasik@xxxxxx>
Subject: RE: [Xen-devel] Vt-d not working with 3.4.1
From: "Teo En Ming (Zhang Enming)" <enming.teo@xxxxxxxxxxxxxxx>
Date: Wed, 19 Aug 2009 17:45:53 +0800
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, weidong.han@xxxxxxxxx, "'Bonenkamp, Ralf'" <ralf.bonenkamp@xxxxxxxx>
Delivery-date: Wed, 19 Aug 2009 02:46:38 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20090819092654.GN19938@xxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Reply-to: enming.teo@xxxxxxxxxxxxxxx
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcograrFDwRI8aUxSYyLthwMUHqVcAAA3yxw
Dear Pasi,

I did a "readelf bzImage" command and it is not an ELF image. I even tried
to do a readelf command on the default kernel (without Xen) that ships with
Fedora 11 and it says not an ELF image too.

Strange. Default installing Fedora 11 kernel not ELF image?

When configuring the pv-ops dom 0 kernel, I always select bzip2 compression.

I also carried out the readelf command on vmlinux and vmlinux.bin in the
arch/x86/boot/compressed directory after compiling the kernel. Both files
reported as ELF 64-bit executable but using vmlinux will NOT boot. Only
using vmlinux.bin will boot.

Mr. Teo En Ming (Zhang Enming) Dip(Mechatronics Engineering)
BEng(Hons)(Mechanical Engineering) 
Technical Support Engineer 
Information Technology Department
Asiasoft Online Pte Ltd
Tampines Central 1 #04-01 Tampines Plaza 
Singapore 529541
Republic of Singapore
Mobile: +65-9648-9798
MSN: teoenming@xxxxxxxxxxx

-----Original Message-----
From: Pasi Kärkkäinen [mailto:pasik@xxxxxx] 
Sent: Wednesday, August 19, 2009 5:27 PM
To: Teo En Ming (Zhang Enming)
Cc: weidong.han@xxxxxxxxx; 'Bonenkamp, Ralf'; xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] Vt-d not working with 3.4.1

On Wed, Aug 19, 2009 at 05:10:47PM +0800, Teo En Ming (Zhang Enming) wrote:
> Hi,
> My hardware configuration is as follows:
> Intel Desktop Board DQ45CB
> BIOS Flashed from version 0063 to 0093
> Intel Pentium Dual Core E6300
> PCI Express x16 Graphics card NVIDIA chipset
> 8 GB DDR2-800
> My software configuration is as follows:
> Fedora 11 64-bit host operating system
> Jeremy's pv-ops dom0 kernel 2.6.30 rc3 and 2.6.31 rc6
> Xen 3.4.1 testing
> When I tried to download and compile Jeremy's pv-ops dom0 kernel, bzImage
> kernel image is compiled successfully for both 2.6.30 rc3 and 2.6.31 rc6.
> However, when I tried to boot using bzImage kernel image, it complains of
> kernel panic on CPU0.
> (XEN) *** LOADING DOMAIN 0 ***
> (XEN) elf_init: not an ELF binary
> I googled around and saw a posting saying to use vmlinux kernel image and
> not the bzImage kernel image.

I'm using arch/x86/boot/bzImage from pv_ops dom0 kernel tree as dom0 kernel,

and it works without problems.

Are you using LZMA compression for the kernel? Maybe that's the problem..

> So I tried to use vmlinux in arch/x86/boot/compressed to boot but it did
> work.

Earlier when Xen didn't support bzImage yet, I used "vmlinux" from the top
directory of kernel tree. It's huge, but you can gzip it to make it a bit

Xen 3.4.x supports bzImage dom0 kernels.

> Not disheartened, I proceeded to try vmlinux.bin as my kernel image.
> Now I can successfully boot up the Xen Dom 0 pv-ops kernel, I can see
> 0 using "xm list" and I can see the Ethernet bridge created and I can also
> surf the internet using a text based browser.
> However, I cannot start X server. It crashed. The system complains about
> some libraries.
> Any idea what goes wrong?

Read "dmesg" and X log.

-- Pasi

No virus found in this incoming message.
Checked by AVG - www.avg.com 
Version: 8.5.392 / Virus Database: 270.13.61/2312 - Release Date: 08/18/09

No virus found in this outgoing message.
Checked by AVG - www.avg.com 
Version: 8.5.392 / Virus Database: 270.13.61/2312 - Release Date: 08/18/09

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>