This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Vt-d not working with 3.4.1

To: "Mr. Teo En Ming (Zhang Enming)" <enming.teo@xxxxxxxxxxxxxxx>
Subject: Re: [Xen-devel] Vt-d not working with 3.4.1
From: Pasi Kärkkäinen <pasik@xxxxxx>
Date: Wed, 19 Aug 2009 15:32:53 +0300
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, weidong.han@xxxxxxxxx, "'Bonenkamp, Ralf'" <ralf.bonenkamp@xxxxxxxx>
Delivery-date: Wed, 19 Aug 2009 05:33:16 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4A8BDE6E.6060804@xxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20090819092654.GN19938@xxxxxxxxxxxxxxx> <FA2BB24021774A8B894CE6721837D720@ASOITIS16> <20090819102014.GO19938@xxxxxxxxxxxxxxx> <4A8BDE6E.6060804@xxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.13 (2006-08-11)
On Wed, Aug 19, 2009 at 07:13:50PM +0800, Mr. Teo En Ming (Zhang Enming) wrote:
> Dear Pasi,
> I suspect that there may be some problems with the Xen 3.4.1 changeset of 6 
> August 2009.
> The bzImage kernel image that I compiled is not a bzip2 file, hence I 
> cannot bzcat it. If I tried to do so, it will complain that it is not a 
> bzip2 file.

What does "file <kernel>" say?

> I did specify the following in my kernel configuration:
> When I do a "xm dmesg" command, I see the following output:
> (XEN) Intel VT-d DMAR tables have been parsed.
> (XEN) Intel VT-d Snoop Control not supported.
> (XEN) Intel VT-d DMA Passthrough not supported.
> (XEN) Intel VT-d Queued Invalidation not supported.
> (XEN) Intel VT-d Interrupt Remapping not supported.
> (XEN) I/O virtualisation enabled
> (XEN) I/O virtualisation for PV guests disabled
> So can I confirm that I have VT-d support enabled?
> I have checked. Both bzImage and vmlinux.bin inside arch/x86/boot are NOT 
> ELF images.

Please run "file bzImage" and "file vmlinux.bin".
> Only vmlinux and vmlinux.bin inside arch/x86/boot/compressed are ELF64 
> images.
> However, vmlinux inside compressed cannot boot successfully.

What's the error with that?

> Only vmlinux.bin inside compressed can boot successfully, and this is what 
> I am using now.

Well good that something works..

> Regarding X server (GUI) unable to start, I have a backtrace inside 
> /var/log/Xorg.0.log.
> It complains about Fatal Server error:
> Caught signal 11. Server aborting.

Can you pastebin the backtrace? Or the whole x.org log.

-- Pasi

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>