This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] Vt-d not working with 3.4.1

To: <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-devel] Vt-d not working with 3.4.1
From: "Bonenkamp, Ralf" <ralf.bonenkamp@xxxxxxxx>
Date: Mon, 17 Aug 2009 17:20:12 +0200
Cc: Ross Philipson <Ross.Philipson@xxxxxxxxxx>
Delivery-date: Mon, 17 Aug 2009 08:21:03 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <831D55AF5A11D64C9B4B43F59EEBF72035FE85F76D@xxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <F528B4FC44C6E048B04DB369486AA8D101E2B55E@xxxxxxxxxxxxxx><20090817143154.GZ24960@xxxxxxxxxxxxxxx> <F528B4FC44C6E048B04DB369486AA8D101E2B85E@xxxxxxxxxxxxxx> <831D55AF5A11D64C9B4B43F59EEBF72035FE85F76D@xxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcofR4EoYS8zkwTASQCZ9KCaATWC1gAAR9IAAAB9SuAAADS2cA==
Thread-topic: [Xen-devel] Vt-d not working with 3.4.1
Hi Ross,

thanks for this clarification! I misinterpreted the iommu_inclusive_mapping=1 
thing in the way that this would prevent the log message ;-)
The interesting point is now that my system booted up fine with AND without 

In both cases hiding a PCI device via pciback.hide at boot time using a grub 
entry was not successful and 'xm pci-list-assignable-devices' returned nothing. 
But I've got this working some weeks before with 3.4.1-rc3 and a different PCIe 
ISDN-board but same mobo. Assigning the PCI to a XP hvm domU worked basically 
but caused a kernel panic ~30sec runtime of the hvm. Unfortunate I needed to 
return the PCIe ISDN-board and therefore I was not able to dig into this any 
further. Now I wanted to continue my tests with the current Xen sources BUT an 
older ISDN board (same vendor but _without_ PLX PCIe-PCI bridge). BTW I read 
somewhere that Vt-d with Q35 only might work with PCIe devices!?!

Nevertheless I will try to collect the PCIe ISDN-board from my colleague to use 
the same hardware setup as before and recheck my config...

Best regards

-----Original Message-----
From: Ross Philipson [mailto:Ross.Philipson@xxxxxxxxxx] 
Sent: Montag, 17. August 2009 16:58
To: Bonenkamp, Ralf; xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: RE: [Xen-devel] Vt-d not working with 3.4.1

The message will remain regardless of whether you set iommu_inclusive_mapping 
or not. The parameter is there to work around the underlying issue but the 
issue is not actually corrected. So the code that generates the message (which 
is detecting discrepancies between the e820 map and the DMAR RMRR values) will 
continue to report this even though you used the parameter. The real question 
is whether you are experiencing some other problems beyond the warning message 
- like a boot hang?


-----Original Message-----
From: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx 
[mailto:xen-devel-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Bonenkamp, Ralf
Sent: Monday, August 17, 2009 10:46 AM
To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: RE: [Xen-devel] Vt-d not working with 3.4.1

Hi Pasi,

Sorry - I forgot to mention that I've tried setting the 
iommu_inclusive_mapping=1 parameter too, but unfortunate I posted the output 
from a previous attempt without this parameter.

The xm dmesg output and the DMAR parsing error remains the same. This was the 
reason posting, because I ran out of ideas...

Best regards
Ralf Bonenkamp

-----Original Message-----
From: Pasi Kärkkäinen [mailto:pasik@xxxxxx] 
Sent: Montag, 17. August 2009 16:32
To: Bonenkamp, Ralf
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] Vt-d not working with 3.4.1

On Sat, Aug 08, 2009 at 11:53:23PM +0200, Bonenkamp, Ralf wrote:
> Hi folks,
> currently I try to setup a new xen host v3.4.1 on top of a Asus P5E-VM
> DO (latest BIOS, Vt-d capable and enabled in BIOS) to migrate my
> extisting HVMs (Win2k3 server) running on Xen v3.3.0 to a new home. I
> want to switch over to 3.4.1 to (hopefully!) passthrough my ISDN board
> to a HVM domU.
> Unfortunate there seem some issue with the VT-d DMAR tables which is
> beyond my knowledge and probably someone has some hint how to proceed?
> :-)

Well did you try iommu_inclusive_mapping=1, like it suggests ?
> (XEN) [VT-D]dmar.c:401: RMRR address range not in reserved memory base =
> 7d600000 end = 7dffffff; iommu_inclusive_mapping=1 parameter may be
> needed.
> (XEN) Intel VT-d DMAR tables have been parsed.

-- Pasi

Xen-devel mailing list

Xen-devel mailing list