This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] Vt-d not working with 3.4.1

To: <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-devel] Vt-d not working with 3.4.1
From: "Bonenkamp, Ralf" <ralf.bonenkamp@xxxxxxxx>
Date: Mon, 17 Aug 2009 16:46:29 +0200
Delivery-date: Mon, 17 Aug 2009 07:47:15 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20090817143154.GZ24960@xxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <F528B4FC44C6E048B04DB369486AA8D101E2B55E@xxxxxxxxxxxxxx> <20090817143154.GZ24960@xxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcofR4EoYS8zkwTASQCZ9KCaATWC1gAAR9IA
Thread-topic: [Xen-devel] Vt-d not working with 3.4.1
Hi Pasi,

Sorry - I forgot to mention that I've tried setting the 
iommu_inclusive_mapping=1 parameter too, but unfortunate I posted the output 
from a previous attempt without this parameter.

The xm dmesg output and the DMAR parsing error remains the same. This was the 
reason posting, because I ran out of ideas...

Best regards
Ralf Bonenkamp

-----Original Message-----
From: Pasi Kärkkäinen [mailto:pasik@xxxxxx] 
Sent: Montag, 17. August 2009 16:32
To: Bonenkamp, Ralf
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] Vt-d not working with 3.4.1

On Sat, Aug 08, 2009 at 11:53:23PM +0200, Bonenkamp, Ralf wrote:
> Hi folks,
> currently I try to setup a new xen host v3.4.1 on top of a Asus P5E-VM
> DO (latest BIOS, Vt-d capable and enabled in BIOS) to migrate my
> extisting HVMs (Win2k3 server) running on Xen v3.3.0 to a new home. I
> want to switch over to 3.4.1 to (hopefully!) passthrough my ISDN board
> to a HVM domU.
> Unfortunate there seem some issue with the VT-d DMAR tables which is
> beyond my knowledge and probably someone has some hint how to proceed?
> :-)

Well did you try iommu_inclusive_mapping=1, like it suggests ?
> (XEN) [VT-D]dmar.c:401: RMRR address range not in reserved memory base =
> 7d600000 end = 7dffffff; iommu_inclusive_mapping=1 parameter may be
> needed.
> (XEN) Intel VT-d DMAR tables have been parsed.

-- Pasi

Xen-devel mailing list