This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Latest xen-3.4-testing hangs on boot with iommu=1, on a

To: Tom Rotenberg <tom.rotenberg@xxxxxxxxx>
Subject: Re: [Xen-devel] Latest xen-3.4-testing hangs on boot with iommu=1, on a Lenovo T500
From: Keir Fraser <keir.fraser@xxxxxxxxxxxxx>
Date: Thu, 16 Jul 2009 11:10:00 +0100
Cc: "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Thu, 16 Jul 2009 03:10:34 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <8686c3cd0907160303o1ea25b54p5c6fbe1d0f9f3f26@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcoF/Lo7NrfcnZlXSJ2khiJm5r6kxwAANmyL
Thread-topic: [Xen-devel] Latest xen-3.4-testing hangs on boot with iommu=1, on a Lenovo T500
User-agent: Microsoft-Entourage/
Well, I would 'make clean' in the xen/ subdirectory just to be sure at this
point. But no, it doesn't really sound like a software issue. Have you tried
iommu_inclusive_mapping Xen boot parameter?

 -- Keir

On 16/07/2009 11:03, "Tom Rotenberg" <tom.rotenberg@xxxxxxxxx> wrote:

> No...
> and i remember that there was a problem of warm boots, so i did a cold
> boot. It's really strange, i have no clew about what can cause it...
> I did 'make install' on a clean repository. There is no chance it had
> any "left-overs", right?
> On Thu, Jul 16, 2009 at 1:00 PM, Keir Fraser<keir.fraser@xxxxxxxxxxxxx> wrote:
>> Did you upgrade the BIOS since your last successful test? There have been
>> problems which can persist across warm reboots. So did you power cycle
>> between tests?
>>  -- Keir
>> On 16/07/2009 10:54, "Tom Rotenberg" <tom.rotenberg@xxxxxxxxx> wrote:
>>> Just bisected the tree, and i found out, that it's not because of Xen,
>>> since even 19607 (which worked for me last time) didn't work. I tried
>>> to play a little bit with some of the BIOS settings, but it didn't
>>> help.
>>> It looks like it's some kind of an hardware problem, which causes the
>>> whole machine to freeze, when trying to work with the IOMMU. Any
>>> suggestions on what to do next? to whom should i send this
>>> information?
>>> Tom
>>> On Thu, Jul 16, 2009 at 11:26 AM, Tom Rotenberg<tom.rotenberg@xxxxxxxxx>
>>> wrote:
>>>> It didn't help.
>>>> I will bisect the tree to find the problem.
>>>> On Wed, Jul 15, 2009 at 8:11 PM, Keir Fraser<keir.fraser@xxxxxxxxxxxxx>
>>>> wrote:
>>>>> I'd say changesets 19625 and 19632 are most likely suspects. You could try
>>>>> reverting those patches, or updating your tree to just before those
>>>>> changesets, and see if that helps.
>>>>>  -- Keir
>>>>> On 15/07/2009 18:03, "Tom Rotenberg" <tom.rotenberg@xxxxxxxxx> wrote:
>>>>>> The last version, i have tried and tested (and it worked), was:
>>>>>> changeset 19607: 1ac7832a2fcd
>>>>>> author: Keir Fraser <keir.fraser@xxxxxxxxxx>
>>>>>> date: Mon May 18 13:54:48 2009 +0100
>>>>>> files: README
>>>>>> On Wed, Jul 15, 2009 at 7:58 PM, Keir Fraser<keir.fraser@xxxxxxxxxxxxx>
>>>>>> wrote:
>>>>>>> On 15/07/2009 17:01, "Tom Rotenberg" <tom.rotenberg@xxxxxxxxx> wrote:
>>>>>>>> I have cloned the latest xen 3,4 testing tree, changeset 19696:
>>>>>>>>         22ef8e900a6d (i386: fix handling of Xen entries in final L2
>>>>>>>> page
>>>>>>>> table), and i have installed it on a Lenovo T500 machine, with VT-d
>>>>>>>> enabled.
>>>>>>> When did it last work with the 3.4 tree?
>>>>>>>  -- Keir

Xen-devel mailing list