This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Latest xen-3.4-testing hangs on boot with iommu=1, on a

To: Keir Fraser <keir.fraser@xxxxxxxxxxxxx>
Subject: Re: [Xen-devel] Latest xen-3.4-testing hangs on boot with iommu=1, on a Lenovo T500
From: Tom Rotenberg <tom.rotenberg@xxxxxxxxx>
Date: Thu, 16 Jul 2009 11:26:25 +0300
Cc: "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Thu, 16 Jul 2009 01:26:51 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=vnjdC9S3lBDPFoErgVWc/PPWvChb8gdHG2MJIF1nb7E=; b=r+62H1zJcJ996e7m6E461NHbDXAVkDf4Y4GsjcC+LxFvAoJhf8f4JBtgfH7utciKVH gtDgIg5Z5275k8UulfaVANYH2ZhjmFR3IFUh3GtyDuk5wut86kp5LG9PUY2KsflHLRll CF9XbLx9/bCOCztnyV5ubzYTN7XlwgT4x4V1Y=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=oHqwcSQ/rNagrO9rRwMW44nQtBkzZlVjJxpJgn/hScU2W77kZuCCVqpd7uP8tkE/vY 3H8h1eeKdb3sz8r+qVbY6j6Uc5dTHBb2Y8f93//vF8Ub5j8kukRcAdqbUxn5s9ezu+OQ 446GkemjtVZnGSNIXll8Uq1/uAhD4qr1xH2oQ=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <C683CC61.FA1D%keir.fraser@xxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <8686c3cd0907151003o34b5f8aay176fc67db4cfca46@xxxxxxxxxxxxxx> <C683CC61.FA1D%keir.fraser@xxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
It didn't help.
I will bisect the tree to find the problem.

On Wed, Jul 15, 2009 at 8:11 PM, Keir Fraser<keir.fraser@xxxxxxxxxxxxx> wrote:
> I'd say changesets 19625 and 19632 are most likely suspects. You could try
> reverting those patches, or updating your tree to just before those
> changesets, and see if that helps.
>  -- Keir
> On 15/07/2009 18:03, "Tom Rotenberg" <tom.rotenberg@xxxxxxxxx> wrote:
>> The last version, i have tried and tested (and it worked), was:
>> changeset 19607: 1ac7832a2fcd
>> author: Keir Fraser <keir.fraser@xxxxxxxxxx>
>> date: Mon May 18 13:54:48 2009 +0100
>> files: README
>> On Wed, Jul 15, 2009 at 7:58 PM, Keir Fraser<keir.fraser@xxxxxxxxxxxxx> 
>> wrote:
>>> On 15/07/2009 17:01, "Tom Rotenberg" <tom.rotenberg@xxxxxxxxx> wrote:
>>>> I have cloned the latest xen 3,4 testing tree, changeset 19696:
>>>>         22ef8e900a6d (i386: fix handling of Xen entries in final L2 page
>>>> table), and i have installed it on a Lenovo T500 machine, with VT-d
>>>> enabled.
>>> When did it last work with the 3.4 tree?
>>>  -- Keir

Xen-devel mailing list