This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] xen.git branch reorg / success with 2.6.30-rc3 pv_ops do

On Thu, May 21, 2009 at 10:08:35AM +0100, Ian Campbell wrote:
> On Mon, 2009-05-18 at 13:50 -0400, Pasi Kärkkäinen wrote:
> [...]
> Thanks for all the info Pasi, I've been trying to repro but not
> successfully. I setup an environment similar to yours (32p h/v and
> kernel, ~512M dom0 RAM, swap) and managed most of an allmodconfig build
> before I ran out of RAM trying to link the final vmlinux.

Thanks for looking into it :)

I have dom0_mem=1024M but dunno if that makes any difference..

> I haven't yet tried different compiler versions, I'm using 4.1.2.

gcc version 4.4.0 20090427 (Red Hat 4.4.0-3) - Fedora 11
gcc version 4.3.2 20081105 (Red Hat 4.3.2-7) - Fedora 10

Those were the versions I tried with..

> Is it always kswap<N> which has the issues? (subsequent traces seem to
> be from the softlockup caused by the original failure, not repeated
> failures). Could you perhaps try reproing with swap disabled?

I went through a couple of the logs lately, and yeah, it seems to be kswapd..
I can try without swap.. late next week, I'm away until that..

> Have you ever tried with a more recent hypervisor? I'm using
> xen-unstable, I guess I should rollback to something based on the FC11
> RPMs and try again.

Nope, I haven't tried newer hypervisor yet.. I can try that aswell.

-- Pasi

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>