This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Re: NX related build failure in latest pv_ops dom0 hacke

To: Christophe Saout <christophe@xxxxxxxx>
Subject: Re: [Xen-devel] Re: NX related build failure in latest pv_ops dom0 hackery tree
From: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Date: Thu, 16 Apr 2009 09:13:18 -0700
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 16 Apr 2009 09:14:32 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1239887761.30384.13.camel@xxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20090404192338.GJ24960@xxxxxxxxxxxxxxx> <49D840D4.1070701@xxxxxxxx> <1239555359.12706.4.camel@xxxxxxxxxxxxxxxxxxxx> <49E4BF6F.2010308@xxxxxxxx> <1239887761.30384.13.camel@xxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20090320)
Christophe Saout wrote:
Hi Jeremy,

In the meantime, you can try to use that tree:


It's the latest tip.git merged with one of the push branches from
Jeremy's git repo and cherry-picked commits from the backend, blkback
and netback trees plus minor merge conflict and compile problem fixups.
It seems feature-complete to me, stable and is able to run DomU domains
without problems.
Does it work with AHCI drives for you? It isn't for me (nor my remerge, so I'm not sure what has broken in the meantime...).

What kind of machine is this?  I have a Thinkpad here (Intel) and it is
working.  However, I have tried booting into the same kernel on a remote
maching (unfortunately, no physical access to the machine) and the exact
same kernel that works on my notebook natively and under Xen as Dom0
does not boot the kernel under Xen on that remote machine (but runs
natively).  I can't tell why, but I suspect it might be AHCI related,
because the machine also uses AHCI, but a different controller.  It is
an AMD machine with this controller:

00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA

I could try to compile netconsole and the NIC driver into the kernel to
capture the kernel messages if that would help.

Well, I've tried it on a newish Intel mobo machine with on-board ahci, and that fails. Another, older, Dell machine using a scsi controller works fine. I haven't tried my laptop yet.

In theory AHCI is ACHI, so the controller vendor shouldn't matter. It may have more to do with interrupt controller configuration or memory layout.

On your failing machine, does it work any better if you switch the controller to compat/legacy mode?


Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>