On Wed, Dec 03, 2008 at 10:15:33AM +0000, Keir Fraser wrote:
> On 03/12/2008 10:13, "Isaku Yamahata" <yamahata@xxxxxxxxxxxxx> wrote:
>
> >> If you are fully virtualised then gmfn should mean gpfn, and
> >> arbitrary_virt_to_machine() is correct, isn't it? I can't see a situation
> >> where arbitrary_virt_to_machine() wouldn't correctly give you a gmfn (after
> >> all, it gets you a machine address in guest context, as its name describes
> >> :-).
> >
> > Oh, you are quite right.
> > Do you agree to rename PHYSDEVOP_pirq_eoi_mfn to PHYSDEVOP_pirq_eoi_gmfn?
>
> Yes, and I'll fix up your patches myself to use a_v_t_m() always.
Thank you so much. Here is the ia64 specific part.
So far ia64 hasn't had arbitrary_virt_to_machine().
diff --git a/include/asm-ia64/maddr.h b/include/asm-ia64/maddr.h
--- a/include/asm-ia64/maddr.h
+++ b/include/asm-ia64/maddr.h
@@ -99,6 +99,7 @@ mfn_to_local_pfn(unsigned long mfn)
#define mfn_to_virt(mfn) (__va((mfn) << PAGE_SHIFT))
#define virt_to_mfn(virt) (__pa(virt) >> PAGE_SHIFT)
#define virt_to_machine(virt) __pa(virt) /* for tpmfront.c */
+#define arbitrary_virt_to_machine(virt) virt_to_machine(ia64_imva(virt))
#define set_phys_to_machine(pfn, mfn) do { } while (0)
--
yamahata
_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxxxxxxxx
http://lists.xensource.com/xen-devel
|