This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] help! error in creating a new domain

To: Xin Zhao <zhaoxin@xxxxxxxxxxxxxx>
Subject: Re: [Xen-devel] help! error in creating a new domain
From: Mark Williamson <Mark.Williamson@xxxxxxxxxxxx>
Date: Tue, 27 Jul 2004 12:23:46 +0100
Cc: "Neugebauer, Rolf" <rolf.neugebauer@xxxxxxxxx>, Steven Hand <Steven.Hand@xxxxxxxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxxxx, Mark.Williamson@xxxxxxxxxxxx
Delivery-date: Tue, 27 Jul 2004 12:23:46 +0100
Envelope-to: Steven.Hand@xxxxxxxxxxxx
In-reply-to: Message from Xin Zhao <zhaoxin@xxxxxxxxxxxxxx> of "Sun, 25 Jul 2004 17:29:05 EDT." <Pine.LNX.4.58.0407251727230.4820@xxxxxxxxxxxxxxxxxxxxx>
> Maybe I am really unlucky. 9  I followed the instructions and was still
> stuck and cannot launch a new domain. This time I will list all operations
> I took. Hope someone can help me out. I guess I ran into a lot problems
> common to newbies. If I can eventually work out, I will publish the
> detailed steps. I believe that will be helpful for newbies like me. :

We're working on a comprehensive user manual for the 2.0 release.  It's in the 
unstable tree right now under active development.  Unfortunately, 2.0 is quite 
different to 1.2, so that doesn't help your immediate problem (until 2.0 is 
released ;-)

> 5. boot to domain0. Success.

Good to hear that works.

> When I tried to copy /proc, the system complain "cp: reading
> `/proc/sys/net/ipv4/route/flush': Invalid argument" and stopped. Then I
> manually copied the rest proc entries that are not copied.

You don't need to copy /proc, just make a mount point for it (i.e. mkdir 
/mnt/domain1/proc).  The contents of proc are generated by the kernel at run 
time (as long as you have a proc entry in fstab) and are never stored on disk.

If you look in /proc, each directory named by a number actually describes the 
details of the process that's currently running on your computer with that 
process ID.  If you start and stop processes, you'll see the entries appear 
and disappear in /proc.

> So I tried to do
> "xc_dom_control.py stop 1", I got "return code 0", then nothing happened.

That will just pause the domain - you should use xc_dom_control.py shutdown 1 
to ask the domain politely to shutdown or xc_dom_control destroy 1 to force it 
to exit (similar to kill -9 under UNIX).

You got a hard drive sharing error because the domain still existed (just 
paused) and so still had access to its disk extents.  Starting it again would 
have resulted in two copies of it, sharing the same disk extents.

It looks like your are having some problems related to domain 0's network 
configuration but I don't specifically know what.  Any ideas, folks?