This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] help! error in creating a new domain

To: Steven Hand <Steven.Hand@xxxxxxxxxxxx>
Subject: Re: [Xen-devel] help! error in creating a new domain
From: Xin Zhao <zhaoxin@xxxxxxxxxxxxxx>
Date: Fri, 23 Jul 2004 20:25:20 -0400 (EDT)
Cc: xen-devel@xxxxxxxxxxxxxxxxxxxxx
Delivery-date: Sat, 24 Jul 2004 01:25:44 +0100
Envelope-to: Steven.Hand@xxxxxxxxxxxx
In-reply-to: <E1Bnpw5-0004QC-00@xxxxxxxxxxxxxxxxx>
References: <E1Bnpw5-0004QC-00@xxxxxxxxxxxxxxxxx>
Thanks for Steven's kind help.

I tried the ways you suggested. For method a and b, they do not solve the
problem and I think my configuration is nothing to do with cdrom.

So I copy all directories from my normal root filesystem including /proc
and /etc/grub.conf. Xen stops complaining "kmod: failed to exec
/sbin/modprobe -s -k binfmt-9653, errno = 8". Now the system seems to
start to boot up. However, it starts to complain the following things:

modprobe: Can't locate module usbcore
[1] Initializing USB controller (ehci-hcd):  modprobe: Can't locate module
[1] [FAILED]
[1] Initializing USB controller (usb-uhci):  modprobe: Can't locate module
[1] [FAILED]
[1] Checking root filesystem
[1] Couldn't find matching filesystem: LABEL=/
[1] [FAILED]
[1] *** An error occurred during the file system check.
[1] *** Dropping you to a shell; the system will reboot
[1] *** when you leave the shell.
[1] Give root password for maintenance

Note that the last complaint "Couldn't find matching filesystem: LABEL=/"
seems to be fatal, because the system exits after I input the root

But what else should I do to fix the problem?



On Fri, 23 Jul 2004, Steven Hand wrote:

> >When I tried to create a new domain "domain 1", I followed the Yan-Ching
> >CHU's guide on :installing quick file systems for new domains in Xen 1.2".
> >But when I do "xc_dom_create.py -Dvmid=1", Xen seems to start to boot with
> >some normal bootup information, but right after several proper messages,
> >Xen dump many messages "kmod: failed to exec /sbin/modprobe -s -k
> >binfmt-9653, errno = 8". I was stuck at this problem for several days.
> >Please help.
> Looks like a problem with trying to access a zisofs cd from dom1 using
> a kernel which doesn't understand that. Two things to try:
>   a) when you compile xenolinux-2.4.25 ensure that you have zisofs
>      support configured in, and/or
>   b) check the config for dom1 to determine why it's trying to access
>      the CD [which I guess may hold a 1.2 demo disk?]
> Note that in general you're better to just put an entire copy of the
> normal root filesystem [used by linux on its own, or by domain 0] onto
> a new partition for domain 1; trying to use the stripped down version
> of stuff on the demo CD is generally less sane.
> cheers,
> S.
> -------------------------------------------------------
> This SF.Net email is sponsored by BEA Weblogic Workshop
> FREE Java Enterprise J2EE developer tools!
> Get your free copy of BEA WebLogic Workshop 8.1 today.
> http://ads.osdn.com/?ad_id=4721&alloc_id=10040&op=click
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxxxx
> https://lists.sourceforge.net/lists/listinfo/xen-devel