[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: loop devices - Xen 3.0.3 problem?

When I try to create bridge 4

/etc/xen/scripts/network-bridge vifnum=4 start

Link veth4 is missing.

I tried increasing the loopback devices in the kernel boot command line using 
And also with max_loop=64, but neither worked.

The former should work if the driver is built into your kernel. If it's not I'm 
not sure if module loading picks up options from the boot-time command line. 
You might need to add a line to your modules.conf or to the line that manually 
loads netloop.

I also have this problem, it started with an upgrade to 3.0.3.

Trying to bring up a vifnum 4 or bigger results in that error (Link veth4 is missing).

It doesn't work when loop is in the kernel, and when is built as a module.
In fact, I tried to build it as a module, and then do:

# modprobe loop max_loop=256
# dmesg|grep loop
loop: loaded (max 256 devices)
# /etc/init.d/xend start

But it will always say that "Link veth4 is missing" if I start something like "/etc/xen/scripts/network-bridge vifnum=4 start".

Tomasz Chmielewski

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.